aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-07 16:24:46 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-08 10:17:17 -0800
commit0b8a8f8ca35557a2618a6257a4cfc6ff98564f54 (patch)
treef831ca2d9cc632e41a1f3bef609d83e20c296e26 /meta-oe/recipes-crypto
parentbaa819d7dde110ff6d067507a383244b7efb6e7b (diff)
downloadmeta-openembedded-contrib-0b8a8f8ca35557a2618a6257a4cfc6ff98564f54.tar.gz
libmcrypt: Run autoreconf steps manually
This helps in re-running the configure generation with autotools 2.70+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb b/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb
index 46e694be4a..0c5fc93190 100644
--- a/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb
+++ b/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb
@@ -14,4 +14,15 @@ UPSTREAM_CHECK_REGEX = "Libmcrypt/(?P<pver>\d+(\.\d+)+)/"
inherit autotools-brokensep gettext binconfig
+do_configure() {
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
+ aclocal
+ libtoolize --automake --copy --force
+ autoconf
+ autoheader
+ automake -a
+ oe_runconf
+}
+
CLEANBROKEN = "1"