aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-19 17:34:58 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-19 18:20:17 -0700
commiteb30a6b92ba45eae63cd8aefa37dc3961ad5b7bb (patch)
tree55c67f5952d7fcc67ff6d26cf8bb3d0d826bd6fb /meta-oe/recipes-core
parentd607d161bf6cb32c152c7841aeee622e6b92534b (diff)
downloadmeta-openembedded-contrib-eb30a6b92ba45eae63cd8aefa37dc3961ad5b7bb.tar.gz
sdbus-c++: Fix build and upgrade to latest git
Fix ptest run while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rwxr-xr-xmeta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest15
-rwxr-xr-xmeta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest6
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb10
3 files changed, 11 insertions, 20 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest
deleted file mode 100755
index 2dc6e1eca1..0000000000
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-set -e
-set -o pipefail
-
-SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )"
-
-${SCRIPTPATH}/sdbus-c++-unit-tests 2>&1 | \
-sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
-sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
-awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
-
-${SCRIPTPATH}/sdbus-c++-integration-tests 2>&1 | \
-sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
-sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
-awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest
new file mode 100755
index 0000000000..5e285b39e0
--- /dev/null
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest
@@ -0,0 +1,6 @@
+#!/bin/sh
+set -e
+
+./sdbus-c++-unit-tests 2>&1 && echo "PASS: sdbus-c++-unit-tests" || echo "FAIL: sdbus-c++-unit-tests"
+
+./sdbus-c++-integration-tests 2>&1 && echo "PASS: sdbus-c++-integration-tests" || echo "FAIL: sdbus-c++-integration-tests"
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb
index f52ba141e1..5422e08dd1 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb
@@ -12,14 +12,14 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-exte
${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap,basu"
PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
-PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock"
+PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DINSTALL_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock"
DEPENDS += "expat"
-SRCREV = "30d9f1d46258c2be4ce29b7f7f168ecdf6d4f328"
-
-SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master"
-SRC_URI += "file://run-ptest"
+PV .= "+git"
+SRCREV = "334fcb8833afb298270531dde369135e4b5b88fd"
+SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master \
+ file://run-ptest"
EXTRA_OECMAKE = "-DBUILD_CODE_GEN=OFF \
-DBUILD_DOC=ON \