aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-04-27 11:47:23 -0500
committerKhem Raj <raj.khem@gmail.com>2023-04-28 10:29:06 -0700
commitc5f330bc9ae72989b8f880aa15e738a3c8fce4e7 (patch)
treee39c559faccc461365d52c41d981796052ef8ee5 /meta-oe/recipes-core
parent72af3a0acb0efea048d452e893fc5d494905ebe2 (diff)
downloadmeta-openembedded-contrib-c5f330bc9ae72989b8f880aa15e738a3c8fce4e7.tar.gz
glfw: add packageconfig and wayland dependencies
GLFW has the ability to use a wayland backend. This patch adds a config for it, but does not enable it by default because it has a dependency on extra-cmake-modules which is provided (most commonly) by meta-qt5-extra. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/glfw/glfw_3.3.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/glfw/glfw_3.3.bb b/meta-oe/recipes-core/glfw/glfw_3.3.bb
index b31bba6b6b..5b0d61241e 100644
--- a/meta-oe/recipes-core/glfw/glfw_3.3.bb
+++ b/meta-oe/recipes-core/glfw/glfw_3.3.bb
@@ -20,7 +20,17 @@ EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DGLFW_BUILD_DOCS=OFF"
CFLAGS += "-fPIC"
-DEPENDS = "libpng libglu zlib libxrandr libxinerama libxi libxcursor"
-REQUIRED_DISTRO_FEATURES = "x11 opengl"
+DEPENDS = "libpng libglu zlib"
+REQUIRED_DISTRO_FEATURES = "opengl"
+ANY_OF_DISTRO_FEATURES = "wayland x11"
+
+# upstream considers x11 and wayland backends mutually exclusive and will
+# prioritize wayland if it is enabled, but wayland has dependencies that cannot
+# be satisfied by this layer so it is disabled by default
+
+PACKAGECONFIG ??= "x11"
+
+PACKAGECONFIG[wayland] = "-DGLFW_USE_WAYLAND=ON,,wayland wayland-native wayland-protocols extra-cmake-modules libxkbcommon"
+PACKAGECONFIG[x11] = ",,libxrandr libxinerama libxi libxcursor"
COMPATIBLE_HOST:libc-musl = "null"