aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-25 18:25:29 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-28 12:12:57 -0700
commit046e7067bfcce64205f660cbd32f4f89b6978740 (patch)
treefe0ae70078fd4af76596a132cf285a6bbed07f04 /meta-oe/recipes-core
parente4aec9b81ef1234168932ad3d3d643d2faad1c52 (diff)
downloadmeta-openembedded-contrib-046e7067bfcce64205f660cbd32f4f89b6978740.tar.gz
mysql-python, lio-utils, openlmi-tools: add conditional PNBLACKLIST like meta-python2 does
* it depends on target python(2) recipes from meta-python2 which are restricted with this conditional since: https://git.openembedded.org/meta-python2/commit/?h=hardknott&id=10c65fc18998d302f34634ffceaf31ab335056dd * telepathy-idle and cherokee from: meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb meta-webserver/recipes-httpd/cherokee/cherokee_git.bb also depend on meta-python2, but use only pythonnative from there, so they aren't blacklisted. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index e9fcf71a76..4bf1402ac4 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -220,7 +220,7 @@ RDEPENDS_packagegroup-meta-oe-dbs ="\
"
RDEPENDS_packagegroup-meta-oe-dbs-python2 ="\
- ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "mysql-python", "", d)} \
+ ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'mysql-python', '', d), "", d)} \
"
RDEPENDS_packagegroup-meta-oe-devtools ="\
@@ -439,7 +439,7 @@ RDEPENDS_packagegroup-meta-oe-extended_remove_riscv64 = "upm libleak mraa sysdig
RDEPENDS_packagegroup-meta-oe-extended_remove_riscv32 = "upm libleak mraa sysdig tiptop"
RDEPENDS_packagegroup-meta-oe-extended-python2 ="\
- ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "openlmi-tools", "", d)} \
+ ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'openlmi-tools', '', d), "", d)} \
"
RDEPENDS_packagegroup-meta-oe-gnome ="\
@@ -916,7 +916,7 @@ RDEPENDS_packagegroup-meta-oe-support_append_x86 = " mcelog mce-inject mce-test
RDEPENDS_packagegroup-meta-oe-support_append_x86-64 = " mcelog mce-inject mce-test open-vm-tools vboxguestdrivers"
RDEPENDS_packagegroup-meta-oe-support-python2 ="\
- ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "lio-utils", "", d)} \
+ ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'lio-utils', '', d), "", d)} \
"
RDEPENDS_packagegroup-meta-oe-support_remove_arm ="numactl"