aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorStefan Schmidt <stefan.schmidt@huawei.com>2021-03-18 20:33:19 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-18 12:43:41 -0700
commit3591919feb92f7879db81a09bed11325cbad26e4 (patch)
tree46c0a0da906409cee37791de4e231759bc146b68 /meta-oe/recipes-core
parentad220639ddb67648d3eb9ddf536613d5999c1e2a (diff)
downloadmeta-openembedded-contrib-3591919feb92f7879db81a09bed11325cbad26e4.tar.gz
plymouth_0.9.5.bb: allow building with musl libc
Plymouth uses rpmatch() which is not provided by musl. Instead we use the standalone rpmatch implementation and add dependencies and LDFLAGS adjustment for musl libs based builds. Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.5.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.5.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.5.bb
index 04106fcc9b..11fb30d480 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.5.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.5.bb
@@ -13,6 +13,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "libcap libpng cairo dbus udev"
+DEPENDS_append_libc-musl = " musl-rpmatch"
PROVIDES = "virtual/psplash"
RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support"
@@ -42,6 +43,8 @@ LOGO ??= "${datadir}/plymouth/bizcom.png"
inherit autotools pkgconfig systemd gettext
+LDFLAGS_append_libc-musl = " -lrpmatch"
+
do_install_append() {
# Remove /var/run from package as plymouth will populate it on startup
rm -fr "${D}${localstatedir}/run"