aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorNick Lewis <nick.lewis@usa.g4s.com>2014-06-16 14:39:20 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 10:36:53 +0200
commita6eaef942529ed9fc511bd86dd00369862297b26 (patch)
tree47881563a70171411b1da7728908903e2801432b /meta-oe/recipes-core
parent87317f52e9b9a22e64454da6ad6cbd48a89ed951 (diff)
downloadmeta-openembedded-contrib-a6eaef942529ed9fc511bd86dd00369862297b26.tar.gz
libxml++: fix ptest target paths
Signed-off-by: Nick Lewis <nick.lewis@usa.g4s.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch23
1 files changed, 16 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
index 1e847be7ac..82960f1120 100644
--- a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
@@ -12,10 +12,19 @@ index d4aadb1..0e36756 100644
# Optional: auto-generate the ChangeLog file from the git log on make dist
include $(top_srcdir)/macros/dist-changelog.am
diff --git a/examples/Makefile.am b/examples/Makefile.am
-index d9541ca..c28b49c 100644
+index d9541ca..c27e088 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
-@@ -36,6 +36,23 @@ check_PROGRAMS = \
+@@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -I. $(LIBXMLXX_CFLAGS)
+ AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS)
+ LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS)
+
++LOG_DRIVER = $(SHELL) ../macros/test-driver
++
+ check_PROGRAMS = \
+ dom_build/dom_build \
+ dom_parse_entities/dom_parse_entities \
+@@ -36,6 +38,23 @@ check_PROGRAMS = \
schemavalidation/schemavalidation \
textreader/textreader
@@ -39,20 +48,20 @@ index d9541ca..c28b49c 100644
# Shell scripts that call the example programs.
check_SCRIPTS = \
dom_build/make_check.sh \
-@@ -147,10 +164,10 @@ dist_noinst_DATA = \
+@@ -147,10 +166,10 @@ dist_noinst_DATA = \
# file are located in different directories.
dom_read_write/make_check.sh: Makefile
echo '# Generated and used by "make check"' >$@
- echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
-+ echo 'dom_read_write/.libs/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
++ echo 'cd dom_read_write && .libs/dom_read_write "example.xml" example_output.xml >/dev/null' >>$@
chmod +x $@
-script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null
-+script_template = cd "$(srcdir)/<!progname!>" && ".libs/<!progname!>" >/dev/null
++script_template = cd "<!progname!>" && ".libs/<!progname!>" >/dev/null
standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
# All other script files are generated like so:
-@@ -162,3 +179,18 @@ $(standard_scripts): Makefile
+@@ -162,3 +181,18 @@ $(standard_scripts): Makefile
CLEANFILES = \
dom_read_write/example_output.xml \
$(check_SCRIPTS)
@@ -65,7 +74,7 @@ index d9541ca..c28b49c 100644
+ $(MKDIR_P) $(DESTDIR)/examples
+ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
+ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
-+ $(foreach i, $(dist_noinst_DATA), cp --parents $(srcdir)/$(i) $(DESTDIR)/examples;)
++ cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
+ cp Makefile $(DESTDIR)/examples
+ $(MKDIR_P) $(DESTDIR)/macros
+ cp $(srcdir)/../macros/test-driver $(DESTDIR)/macros