aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2013-05-29 03:46:08 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-12 16:23:22 +0200
commit8b9c1d22135694e6e20d9e77ee1524e0fba93ec9 (patch)
tree49bb57747c6e8aec087033699f754ca441e16a06 /meta-oe/recipes-core
parenta3ccaa1009bcbb852f2a95c5982df2af14b1b7ad (diff)
downloadmeta-openembedded-contrib-8b9c1d22135694e6e20d9e77ee1524e0fba93ec9.tar.gz
llvm: disable build rpath
This avoids QA Issue where tblgen has an rpath to lib in the shadow build directory. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/llvm/llvm.inc1
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.9_2.9.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm.inc b/meta-oe/recipes-core/llvm/llvm.inc
index 27f8c84b05..6cf9db8d79 100644
--- a/meta-oe/recipes-core/llvm/llvm.inc
+++ b/meta-oe/recipes-core/llvm/llvm.inc
@@ -62,6 +62,7 @@ EXTRA_OECMAKE = "\
-DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
-DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
"
# We need to reset this to avoid breakage as we build out of tree
TOOLCHAIN_OPTIONS = ""
diff --git a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
index ee7c3a3cfb..1cd68be11c 100644
--- a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
+++ b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
@@ -34,6 +34,7 @@ EXTRA_OECMAKE = "\
-DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
-DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
"
LLVM_RELEASE = "2.9"