aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-06-15 12:03:57 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-14 22:31:44 -0700
commit12072f84377897de9117481c9d173d71f4e0b307 (patch)
treecbd9b10e35f5c494b1885e23444e2182a464a915 /meta-oe/recipes-core
parentcb56ed6a9df5675f72c4bdc34d641f8184115059 (diff)
downloadmeta-openembedded-contrib-12072f84377897de9117481c9d173d71f4e0b307.tar.gz
opencl-clhpp: add recipe
Recipe to provide OpenCL API C++ bindings. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/opencl/opencl-clhpp_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb b/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
new file mode 100644
index 0000000000..a4f2924755
--- /dev/null
+++ b/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "OpenCL API C++ bindings"
+DESCRIPTION = "OpenCL API C++ bindings from Khronos"
+
+SRC_URI = "git://github.com/KhronosGroup/OpenCL-CLHPP.git;protocol=https"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "2.0.11+git${SRCPV}"
+SRCREV = "432b551429b362a877ed9b647b7114022b332be0"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = " \
+ -DBUILD_DOCS=OFF \
+ -DBUILD_EXAMPLES=OFF \
+ -DBUILD_TESTS=OFF \
+ "
+
+# Headers only so PN is empty
+RDEPENDS_${PN}-dev = ""