aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorNg, Wei Tee <wei.tee.ng@intel.com>2017-05-21 12:15:23 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:44 +0200
commit1fc882cdc477633207db0236619d8f447fad7563 (patch)
treeb5342d1f0c3d107bd0e1f55b9e24a12c008f269c /meta-oe/recipes-core
parentc39a815c8e852ec7c47063cf00c47166a64eb8fb (diff)
downloadmeta-openembedded-contrib-1fc882cdc477633207db0236619d8f447fad7563.tar.gz
dbus-daemon-proxy: inherit pkgconfig, unblacklist and set package version
The pkgconfig is not found in recipes specific sysroot. Therefore inherit pkgconfig is added to fix it. Package version is updated to avoid package dbus-daemon-proxy-dbg went backwards which would break package feeds. Signed-off-by: Ng, Wei Tee <wei.tee.ng@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
index a953ebc28e..4571b447f2 100644
--- a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
+++ b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
@@ -4,13 +4,15 @@ LIC_FILES_CHKSUM = "file://dbus-daemon-proxy.c;endline=19;md5=41df6d21fe1c97d6a1
DEPENDS = "dbus dbus-glib"
SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
PV = "0.0.0+gitr${SRCPV}"
-PR = "r1"
+PR = "r1.59"
ASNEEDED_pn-dbus-daemon-proxy = ""
SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy"
S = "${WORKDIR}/git"
+inherit pkgconfig
+
do_compile() {
${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c
}
@@ -19,6 +21,3 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 dbus-daemon-proxy ${D}${bindir}
}
-
-
-PNBLACKLIST[dbus-daemon-proxy] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130613/ - the recipe will be removed on 2017-09-01 unless the issue is fixed"