summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd/systemd_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-28 14:30:45 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-28 16:42:55 +0200
commit73ee0542d93ed095233f909184b79e0c7184a38a (patch)
treec2764cf4bef08a9870879ec86de044632629bf14 /meta-oe/recipes-core/systemd/systemd_git.bb
parent086a042fb75d79902c84d81dc1e3caa5dd995c16 (diff)
downloadmeta-openembedded-contrib-73ee0542d93ed095233f909184b79e0c7184a38a.tar.gz
systemd: add u-a entries for reboot, halt and friends
Also drag in full modprobe. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd_git.bb')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb25
1 files changed, 18 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 9f92f8ace7..d1f4cbed91 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -15,7 +15,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r1"
+PR = "r2"
inherit autotools vala update-alternatives
@@ -88,13 +88,24 @@ FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debu
RDEPENDS_${PN} += "dbus-systemd udev-systemd"
# kbd -> loadkeys,setfont
-RRECOMMENDS_${PN} += "kbd kbd-consolefonts ${PN}-serialgetty"
+# systemd calls 'modprobe -sab --', which busybox doesn't support due to lack
+# of blacklist support, so use proper modprobe from module-init-tools
+RRECOMMENDS_${PN} += "kbd kbd-consolefonts ${PN}-serialgetty module-init-tools"
+
+# TODO:
+# u-a for runlevel and telinit
pkg_postinst_${PN} () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- grep "^lock:" /etc/group > /dev/null || addgroup lock
+# can't do this offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+grep "^lock:" /etc/group > /dev/null || addgroup lock
+
+update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
+update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
+update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
+update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
+
}