aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
commitc58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch)
tree3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb
parenteec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff)
downloadmeta-openembedded-contrib-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz
move layer into meta-oe in preparation for future splits
As per TSC decision Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb')
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb
new file mode 100644
index 0000000000..c265749f64
--- /dev/null
+++ b/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "\
+ ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch \
+"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${includedir}/fakeroot
+ install -m 644 *.h ${D}${includedir}/fakeroot
+ install -d ${D}${libdir}/libfakeroot/
+ oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
+}
+
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS_${PN} = "util-linux"
+
+
+SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
+SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"