aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
diff options
context:
space:
mode:
authorAndré Draszik <adraszik@tycoint.com>2016-11-25 15:18:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:23:44 +0100
commit119e75e48dbf0539b4e440417901458ffff79b38 (patch)
tree6c91f760954965e79f860474dd4183025fa51528 /meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
parent45837e6c567b1b9ff9d152a7e2a752488d313455 (diff)
downloadmeta-openembedded-contrib-119e75e48dbf0539b4e440417901458ffff79b38.tar.gz
libdbus-c++: missing DEPENDS, fix musl build, oe-stylize.py
- libdbus-c++ also depends on expat - use PACKAGE_BEFORE_PN to simplify FILES - run through oe-stylize.py - compiling against the musl C library showed various problems, which have been fixed with the patches attached Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb')
-rw-r--r--meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
index 7edaffca6b..9b053fed84 100644
--- a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
+++ b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
@@ -4,21 +4,26 @@ HOMEPAGE = "http://dbus-cplusplus.sourceforge.net"
SECTION = "base"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS = "dbus glib-2.0 libpcre"
+DEPENDS = "dbus expat glib-2.0 libpcre"
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BPN}-${PV}.tar.gz \
- file://fix-missing-unistd.h-include.patch \
- file://remove-CXX_FOR_BUILD-stuff.patch"
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \
+ file://fix-missing-unistd.h-include.patch \
+ file://remove-CXX_FOR_BUILD-stuff.patch \
+ file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \
+ file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \
+ file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \
+ file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \
+"
SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2"
SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61"
-EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
-
inherit autotools pkgconfig
-PACKAGES += "${PN}-tools"
+EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
+
+PACKAGE_BEFORE_PN = "${PN}-tools"
-FILES_${PN} = "${libdir}"
FILES_${PN}-tools = "${bindir}"
BBCLASSEXTEND = "native"