aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2020-06-11 13:40:30 +0200
committerKhem Raj <raj.khem@gmail.com>2020-06-11 21:58:29 -0700
commit1b809dba989fc67b1834a30b5c69adb383a38245 (patch)
tree96691884949ae21b85f5c8acba6c5824436d6346 /meta-oe/recipes-connectivity
parent9239584e717bb2093c9bfd6972bb2f01507ab859 (diff)
downloadmeta-openembedded-contrib-1b809dba989fc67b1834a30b5c69adb383a38245.tar.gz
thrift: drop unsupported features
- QT4 support was dropped - Feature for switching between boost and std pointer was dropped - only std pointers are supported since version 0.13.0 Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb
index 92bcb21bf1..e3880b357a 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb
+++ b/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb
@@ -24,7 +24,6 @@ export BUILD_SYS
export HOST_SYS
EXTRA_OECMAKE = " \
- -DENABLE_PRECOMPILED_HEADERS=OFF \
-DBUILD_LIBRARIES=ON \
-DBUILD_COMPILER=ON \
-DBUILD_TESTING=OFF \
@@ -36,15 +35,12 @@ EXTRA_OECMAKE = " \
-DWITH_STATIC_LIB=ON \
-DWITH_SHARED_LIB=ON \
-DWITH_OPENSSL=ON \
- -DWITH_QT4=OFF \
-DWITH_QT5=OFF \
- -DWITH_BOOST_FUNCTIONAL=OFF \
"
-PACKAGECONFIG ??= "libevent glib boost-smart-ptr"
+PACKAGECONFIG ??= "libevent glib"
PACKAGECONFIG[libevent] = "-DWITH_LIBEVENT=ON,-DWITH_LIBEVENT=OFF,libevent"
PACKAGECONFIG[glib] = "-DWITH_C_GLIB=ON,-DWITH_C_GLIB=OFF,glib-2.0"
-PACKAGECONFIG[boost-smart-ptr] = "-DWITH_BOOST_SMART_PTR=ON,-DWITH_BOOST_SMART_PTR=OFF,boost"
do_install_append () {
ln -sf thrift ${D}/${bindir}/thrift-compiler