aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorAdrian Freihofer <adrian.freihofer@gmail.com>2022-03-03 14:06:16 +0100
committerKhem Raj <raj.khem@gmail.com>2022-03-03 23:07:50 -0800
commitd6a72c62dd1eb9a1b84ff2c1aa6a6c7707955e46 (patch)
tree8b4e1b8e71fcffdabee64c38674a1d04ec983193 /meta-oe/recipes-connectivity
parent7a7604faad34633f77c6c36e1df68070c3da576f (diff)
downloadmeta-openembedded-contrib-d6a72c62dd1eb9a1b84ff2c1aa6a6c7707955e46.tar.gz
libqmi: switch to meson and git
- Switching to meson and git because of the following statement from news file: "The next major release will likely be a meson-only one, and will therefore not be based on a source release tarball any more, but on specific git tags instead." - Add PACKAGECONFIG for qrtr. - Updateing deprecated licenses acc. to https://gitlab.freedesktop.org/mobile-broadband/libqmi/#license Signed-off-by: Adrian Freihofer <adrian.freihofer@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/libqmi/files/0001-build-use-python3-everywhere.patch33
-rw-r--r--meta-oe/recipes-connectivity/libqmi/libqmi_1.30.4.bb23
2 files changed, 50 insertions, 6 deletions
diff --git a/meta-oe/recipes-connectivity/libqmi/files/0001-build-use-python3-everywhere.patch b/meta-oe/recipes-connectivity/libqmi/files/0001-build-use-python3-everywhere.patch
new file mode 100644
index 0000000000..e345d28031
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libqmi/files/0001-build-use-python3-everywhere.patch
@@ -0,0 +1,33 @@
+From 189528e879e4099b44aae26a2af0cb16aaa96db6 Mon Sep 17 00:00:00 2001
+From: goapunk <goapunk@riseup.net>
+Date: Mon, 13 Sep 2021 13:45:41 +0200
+Subject: [PATCH] build: use python3 everywhere
+
+---
+ build-aux/qmi-codegen/qmi-codegen | 2 +-
+ examples/simple-tester-python/simple-tester-python | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/build-aux/qmi-codegen/qmi-codegen b/build-aux/qmi-codegen/qmi-codegen
+index 1fea7c1..1092c8e 100755
+--- a/build-aux/qmi-codegen/qmi-codegen
++++ b/build-aux/qmi-codegen/qmi-codegen
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- Mode: python; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+ #
+ # This program is free software; you can redistribute it and/or modify it under
+diff --git a/examples/simple-tester-python/simple-tester-python b/examples/simple-tester-python/simple-tester-python
+index af9065a..a35e505 100755
+--- a/examples/simple-tester-python/simple-tester-python
++++ b/examples/simple-tester-python/simple-tester-python
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- Mode: python; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+ #
+ # This program is free software; you can redistribute it and/or modify it under
+--
+2.34.1
+
diff --git a/meta-oe/recipes-connectivity/libqmi/libqmi_1.30.4.bb b/meta-oe/recipes-connectivity/libqmi/libqmi_1.30.4.bb
index dee36d7b45..4807244a58 100644
--- a/meta-oe/recipes-connectivity/libqmi/libqmi_1.30.4.bb
+++ b/meta-oe/recipes-connectivity/libqmi/libqmi_1.30.4.bb
@@ -2,7 +2,7 @@ SUMMARY = "libqmi is a library for talking to WWAN devices by QMI protocol"
DESCRIPTION = "libqmi is a glib-based library for talking to WWAN modems and \
devices which speak the Qualcomm MSM Interface (QMI) protocol"
HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libqmi"
-LICENSE = "GPLv2 & LGPLv2.1"
+LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
LIC_FILES_CHKSUM = " \
file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
@@ -10,12 +10,23 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "glib-2.0 glib-2.0-native"
-inherit autotools pkgconfig bash-completion gobject-introspection
+inherit meson pkgconfig bash-completion gobject-introspection
-SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz"
+SRCREV ?= "f6c2feaf199e0f129a0bde8c5e6cba5f2117b564"
+# patch 0001 is on main branch upstream
+SRC_URI = "\
+ git://gitlab.freedesktop.org/mobile-broadband/libqmi.git;protocol=https;branch=qmi-1-30 \
+ file://0001-build-use-python3-everywhere.patch \
+"
-SRC_URI[sha256sum] = "00d7da30a4f8d1185f37cba289cfaf1dfcd04a58f2f76d6acfdf5b85312d6ed6"
+S = "${WORKDIR}/git"
PACKAGECONFIG ??= "udev mbim"
-PACKAGECONFIG[udev] = ",--without-udev,libgudev"
-PACKAGECONFIG[mbim] = "--enable-mbim-qmux,--disable-mbim-qmux,libmbim"
+PACKAGECONFIG[udev] = "-Dudev=true,-Dudev=false,libgudev"
+PACKAGECONFIG[mbim] = "-Dmbim_qmux=true,-Dmbim_qmux=false,libmbim"
+PACKAGECONFIG[qrtr] = "-Dqrtr=true,-Dqrtr=false,libqrtr-glib"
+
+EXTRA_OEMESON = " \
+ -Dgtk_doc=false \
+ -Dman=false \
+"