aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorAnkit Navik <ankit.tarot@gmail.com>2017-02-26 17:29:21 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:52 +0100
commitff483494be3b812194149261f9a9db9dcb16256b (patch)
treed7c2e08e899a93ded4accfe10b23fe5e9599d5f0 /meta-oe/recipes-connectivity
parent131255dd561225d7e4ebbf5155420a685dfebf6e (diff)
downloadmeta-openembedded-contrib-ff483494be3b812194149261f9a9db9dcb16256b.tar.gz
ell: Initial recipe for Embedded Linux Library
Add generic recipe for ELL. Signed-off-by: Ankit Navik <ankit.tarot@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/ell/ell_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/ell/ell_git.bb b/meta-oe/recipes-connectivity/ell/ell_git.bb
new file mode 100644
index 0000000000..d259f52aca
--- /dev/null
+++ b/meta-oe/recipes-connectivity/ell/ell_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Embedded Linux Library"
+DESCRIPTION = "ELL is a DBUS library which provides DBUS bindings."
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+SECTION = "libs"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+SRCREV = "399099946abaeb2f3718a0667cc11436a7c0be14"
+SRC_URI = "git://git.kernel.org/pub/scm/libs/ell/ell.git"
+
+do_configure_prepend () {
+ mkdir ${S}/build-aux
+}
+
+DEPENDS = "dbus"