aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-06-02 16:04:56 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:44 +0200
commitb58c258b6e93d4f932faf526a8b32434b1d440e7 (patch)
treeabe67df6c0bba9e1b48d1817876d3f39e1f1eeda /meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
parentfb26fdcda0b719512fac4760e680b213c0b016c0 (diff)
downloadmeta-openembedded-contrib-b58c258b6e93d4f932faf526a8b32434b1d440e7.tar.gz
umip: fix for parallel compilation
Add missing dependency in Makefile to fix the parallel compile issue and re-enable PARALLEL_MAKE Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch')
-rw-r--r--meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
new file mode 100644
index 0000000000..dbf0082640
--- /dev/null
+++ b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
@@ -0,0 +1,23 @@
+When "make -j10", the compilation will fail,
+because scan.c has included gram.h, but gram.h was produced
+after scan.c was compiled
+
+So add this dependency to ensure that gram.h is produced
+before scan.c is produced.
+
+Upstream-Status: Inappropriate [upstream is not active]
+
+Signed-off-by: Roy.Li <RongQing.Li@windriver.com>
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ src/Makefile.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -81,3 +81,5 @@ CLEANFILES = gram.c gram.h \
+
+ DISTCLEANFILES = $(BUILT_SOURCES)
+ MAINTAINERCLEANFILES = Makefile.in
++
++scan.c: gram.h