aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/uhd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-02 18:32:50 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-02 21:43:27 +0200
commit4a8dece451c31bce1d6e7add0b5474c388df7749 (patch)
tree269241a5029081df0efe8bab476870b2b9434ec9 /meta-oe/recipes-connectivity/uhd
parent042b5bd5444769108e208d8f9eb3645f414fb42f (diff)
downloadmeta-openembedded-contrib-4a8dece451c31bce1d6e7add0b5474c388df7749.tar.gz
uhd: update to 3.2.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/uhd')
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd.inc15
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch20
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd_git.bb5
3 files changed, 29 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd.inc b/meta-oe/recipes-connectivity/uhd/uhd.inc
index e6a71bc26f..b08d1a0662 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd.inc
+++ b/meta-oe/recipes-connectivity/uhd/uhd.inc
@@ -3,10 +3,11 @@ HOMEPAGE = "http://www.ettus.com"
LICENSE = "GPLV3+"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51b35d652c070d136bf20244494be2d3"
-DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware"
+DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware orc-native"
RDEPENDS_${PN} += "uhd-firmware"
-INC_PR = "r4"
+PE = "1"
+INC_PR = "r0"
inherit cmake
@@ -15,14 +16,16 @@ PACKAGES =+ "${PN}-tests ${PN}-examples"
FILES_${PN} += "${libdir}/libuhd.so"
FILES_${PN} += "${datadir}/uhd/utils/*"
FILES_${PN}-tests += "${datadir}/uhd/tests/*"
-FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug/*"
-FILES_${PN}-dbg += "${datadir}/uhd/utils/.debug/*"
-FILES_${PN}-dbg += "${datadir}/uhd/tests/.debug/*"
+FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug \
+ ${datadir}/uhd/utils/.debug \
+ ${datadir}/uhd/tests/.debug \
+ ${datadir}/uhd/usrp_e_utils/.debug \
+ "
FILES_${PN}-examples = "${datadir}/uhd/examples/*"
OECMAKE_BUILDPATH = "${S}/build"
OECMAKE_SOURCEPATH = "${S}"
-EXTRA_OECMAKE = "-DENABLE_USRP_E100=TRUE"
+EXTRA_OECMAKE = "-DENABLE_E100=TRUE -DENABLE_USRP_E_UTILS=TRUE"
EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
index 2bce7c388c..eb05cc0a04 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
+++ b/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
@@ -1,12 +1,13 @@
-From e5d7ae406cb7770c4fe4886bd162c18bf6ca2904 Mon Sep 17 00:00:00 2001
+From 77be3026cbfe77b3ee1aaa549a27f5ad50320f9d Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Fri, 17 Jun 2011 19:44:04 +0200
Subject: [PATCH] HACK: work around -Wl,as-needed problems
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
---
- host/lib/types/CMakeLists.txt | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
+ host/lib/types/CMakeLists.txt | 2 +-
+ host/usrp_e_utils/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/host/lib/types/CMakeLists.txt b/host/lib/types/CMakeLists.txt
index 957dfd3..3147747 100644
@@ -21,6 +22,19 @@ index 957dfd3..3147747 100644
ELSEIF(HAVE_MACH_ABSOLUTE_TIME)
MESSAGE(STATUS " High resolution timing supported through mach_absolute_time.")
SET(TIME_SPEC_DEFS HAVE_MACH_ABSOLUTE_TIME)
+diff --git a/host/usrp_e_utils/CMakeLists.txt b/host/usrp_e_utils/CMakeLists.txt
+index 9162a20..18414ad 100644
+--- a/host/usrp_e_utils/CMakeLists.txt
++++ b/host/usrp_e_utils/CMakeLists.txt
+@@ -38,7 +38,7 @@ IF(ENABLE_USRP_E_UTILS)
+ FOREACH(util_source ${usrp_e_utils_sources})
+ GET_FILENAME_COMPONENT(util_name ${util_source} NAME_WE)
+ ADD_EXECUTABLE(${util_name} ${util_source})
+- TARGET_LINK_LIBRARIES(${util_name} ${Boost_LIBRARIES})
++ TARGET_LINK_LIBRARIES(${util_name} ${Boost_LIBRARIES} -lpthread -lncurses)
+ INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${PKG_DATA_DIR}/usrp_e_utils)
+ ENDFOREACH(util_source)
+
--
1.6.6.1
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
index ad3385ae47..329a39598b 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb
+++ b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
@@ -1,9 +1,10 @@
require uhd.inc
-PR = "${INC_PR}.4"
+PV = "3.2.1"
+PR = "${INC_PR}.0"
SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;protocol=git \
file://0001-HACK-work-around-Wl-as-needed-problems.patch;striplevel=2"
S = "${WORKDIR}/git/host"
-SRCREV = "0aff497dacc9cc4eba5d800cc46343da083cfdf1"
+SRCREV = "fc349d30507620baca935e75e68a9554b40d427c"