aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-04 16:19:13 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2015-01-05 10:56:37 +0000
commit3e885d401bb47a7fa5a53b39101bb729da7d522f (patch)
treeceb89d1fab3f9c71cf389a1ba930fb228c0eb355 /meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb
parenta050b987768b6f8cd40b44aae13716e39b942c96 (diff)
downloadmeta-openembedded-contrib-3e885d401bb47a7fa5a53b39101bb729da7d522f.tar.gz
rfkill: update to 0.5
Also make SUMMARY a bit more useful. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb')
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb b/meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb
new file mode 100644
index 0000000000..3e644760ce
--- /dev/null
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill_0.5.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Radio enable/disable command line utility"
+HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
+SECTION = "base"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94"
+
+SRC_URI = "http://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.bz2 \
+ file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch \
+ file://dont.call.git.rev-parse.on.parent.dir.patch"
+
+SRC_URI[md5sum] = "b957713a6cfbcd8ac0e94420aeddcf1a"
+SRC_URI[sha256sum] = "3e160cca504a53679f2b3254f31c53a4fb38a021bc50fed8eb57a436d33dfa07"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "rfkill"
+ALTERNATIVE_PRIORITY = "60"
+ALTERNATIVE_LINK_NAME[rfkill] = "${sbindir}/rfkill"
+