aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/obexftp
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2014-03-07 15:26:10 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-15 15:25:27 +0100
commit2e7e9bec4882ee0a01e1a13cd8d981f2fd15c639 (patch)
tree48a1435c17af6f7627b180219bb0868dbeab8f7a /meta-oe/recipes-connectivity/obexftp
parent095fbd60d7b0b59558e49b97a20814d34626084e (diff)
downloadmeta-openembedded-contrib-2e7e9bec4882ee0a01e1a13cd8d981f2fd15c639.tar.gz
obexftp: Create 0.23 version
obexftp is a tool to transfer files from any OBEX enabled device. Disable prints to improve performance Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/obexftp')
-rw-r--r--meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch34
-rw-r--r--meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb16
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch b/meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch
new file mode 100644
index 0000000000..8b73af32e8
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch
@@ -0,0 +1,34 @@
+Signed-off-by: Jun Zhu <R01007@freescale.com>
+
+Upstream-Status: Not applicable
+
+diff -Nru obexftp-0.23/apps.orig/obexftpd.c obexftp-0.23/apps/obexftpd.c
+--- obexftp-0.23/apps.orig/obexftpd.c 2013-11-08 10:42:20.816631583 +0800
++++ obexftp-0.23/apps/obexftpd.c 2013-11-08 10:44:18.628634893 +0800
+@@ -639,7 +639,7 @@
+ struct stat statbuf;
+ //char *namebuf = NULL;
+
+- fprintf(stderr, "put_done>>>\n");
++ //fprintf(stderr, "put_done>>>\n");
+ while(OBEX_ObjectGetNextHeader(handle, object, &hi, &hv, &hlen)) {
+ switch(hi) {
+ case OBEX_HDR_BODY:
+@@ -671,7 +671,7 @@
+ }
+ }
+ if(!body) {
+- printf("Got a PUT without a body\n");
++ //printf("Got a PUT without a body\n");
+ OBEX_ObjectSetRsp(object, OBEX_RSP_CONTINUE, OBEX_RSP_SUCCESS);
+ }
+ if(!name) {
+@@ -807,7 +807,7 @@
+
+ switch(obex_cmd) {
+ case OBEX_CMD_PUT:
+- fprintf(stderr, "obex_ev_progress: obex_cmd_put\n");
++ //fprintf(stderr, "obex_ev_progress: obex_cmd_put\n");
+ put_done(handle, obj, 0);
+ break;
+ default:
diff --git a/meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb b/meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb
new file mode 100644
index 0000000000..b6bdfb7e43
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A tool for transfer files to/from any OBEX enabled device"
+LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+DEPENDS += "openobex"
+
+SRC_URI = "http://sourceforge.net/projects/openobex/files/obexftp/${PV}/obexftp-${PV}.tar.bz2 \
+ file://Remove_some_printf_in_obexftpd.patch "
+
+SRC_URI[md5sum] = "f20762061b68bc921e80be4aebc349eb"
+SRC_URI[sha256sum] = "44a74ff288d38c0f75354d6bc2efe7d6dec10112eaff2e7b10e292b0d2105b36"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--disable-tcl --disable-perl --disable-python --disable-ruby"
+