aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-07-01 17:48:33 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-15 15:02:28 +0200
commitf52c0d42f4b87cb3cf925bed09bf116c0e4fbaaf (patch)
tree26a73212756e464e09bbe19970787199a6885fee /meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
parent31f6f1aa6c6a9a762213435121408a2303b9ce63 (diff)
downloadmeta-openembedded-contrib-f52c0d42f4b87cb3cf925bed09bf116c0e4fbaaf.tar.gz
linuxptp: Use environment compiler settings
If the machine uses hard floating point, the build fails as below: arm-oel-linux-gnueabi-gcc -Wall ... In file included from .../build/tmp/sysroots/imx6qsabresd/usr/include/features.h:402:0, from .../build/tmp/sysroots/imx6qsabresd/usr/include/errno.h:28, from clock.c:19: .../build/tmp/sysroots/imx6qsabresd/usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory # include <gnu/stubs-soft.h> This patch fixes the build system to reuse the CC variable and also passes over the defined CFLAGS so the choosen optimization and build options are respected. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb')
-rw-r--r--meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
index 10d674405f..4ee0c8873b 100644
--- a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
+++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
@@ -2,13 +2,14 @@ DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz"
+SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
+ file://build-Allow-CC-and-prefix-to-be-overriden.patch"
SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf"
SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} ARCH=${TARGET_ARCH} \
- EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC'"
+EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
+ EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC ${CFLAGS}'"
do_install () {
install -d ${D}/${bindir}