aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-10-01 23:36:44 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:25 +0200
commitc9a41e656f5d8dc01eae6ce83ab9afe29b749826 (patch)
tree1577f82d84539940a832c1f0f3b7acf186ee410f /meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
parenta5618c6f15415e4ab27f3ce1afb66276a7b808b0 (diff)
downloadmeta-openembedded-contrib-c9a41e656f5d8dc01eae6ce83ab9afe29b749826.tar.gz
krb5: Add PACKAGECONFIG and new configure param to disable keyutils detection
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb')
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
index 820a13515b..d0dfc46bf6 100644
--- a/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
@@ -8,7 +8,9 @@ DEPENDS = "ncurses util-linux e2fsprogs e2fsprogs-native"
inherit autotools binconfig perlnative
SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
-SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${SHRT_VER}/${P}-signed.tar"
+SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${SHRT_VER}/${P}-signed.tar \
+ file://0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch \
+"
SRC_URI[md5sum] = "56f0ae274b285320b8a597cb89442449"
SRC_URI[sha256sum] = "9abd94bb94a70996da0f8d90408957154bb543271b097e86c63eb33e5f5751b5"
@@ -17,6 +19,7 @@ S = "${WORKDIR}/${P}/src/"
PACKAGECONFIG ??= "openssl"
PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
PACKAGECONFIG[openssl] = "--with-pkinit-crypto-impl=openssl,,openssl"
+PACKAGECONFIG[keyutils] = "--enable-keyutils,--disable-keyutils,keyutils"
EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath"
CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
@@ -42,5 +45,6 @@ python do_unpack() {
do_configure() {
gnu-configize --force
+ autoreconf
oe_runconf
}