aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2020-02-04 20:23:07 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-04 22:03:14 -0800
commite2bf7b572c2e47b838dde2112f4af91f3da10cea (patch)
tree7cd327f529dbd8329789162b75b3a3536b55460e /meta-oe/recipes-connectivity/iwd
parente44ff416216f970d18b98ba90eb02d1a6bb18b69 (diff)
downloadmeta-openembedded-contrib-e2bf7b572c2e47b838dde2112f4af91f3da10cea.tar.gz
iwd: Add PACKAGECONFIG options
Make it easier to disable optional client, monitor, and man page components and their dependencies. A user may want to disable the client to avoid the use of GPLv3 readline. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index ed8f21ac1b..cfced50a0e 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
inherit autotools pkgconfig systemd python3native
-DEPENDS = "ell readline python3-docutils-native"
+DEPENDS = "ell"
SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
@@ -13,7 +13,15 @@ SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261"
S = "${WORKDIR}/git"
-PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG ??= " \
+ client \
+ monitor \
+ manual-pages \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+"
+PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
+PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
+PACKAGECONFIG[manual-pages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
@@ -27,6 +35,8 @@ do_configure_prepend () {
do_install_append() {
mkdir --parents ${D}${docdir}/${BPN}
install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN}
+ # If client and monitor are disabled, bindir is empty, causing a QA error
+ rmdir --ignore-fail-on-non-empty ${D}/${bindir}
}
FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_unitdir}/network/"