aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iw
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-29 17:05:38 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-29 17:07:14 +0100
commit300e13209f258f44ba74af5c42bb19dd1c6120a1 (patch)
tree45191b5dcc6bff0001b9934dd9027c8763742451 /meta-oe/recipes-connectivity/iw
parent83f38bacb1e0327f289eae089ae93e4a497a8062 (diff)
downloadmeta-openembedded-contrib-300e13209f258f44ba74af5c42bb19dd1c6120a1.tar.gz
iw: fix build breakage with top-level git repos
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/iw')
-rw-r--r--meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch44
-rw-r--r--meta-oe/recipes-connectivity/iw/iw_3.2.bb6
2 files changed, 49 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch b/meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch
new file mode 100644
index 0000000000..dfe3ca1eb4
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch
@@ -0,0 +1,44 @@
+From 5310abba864cfe3a8b65af130729447604190b29 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 29 Nov 2011 17:03:27 +0100
+Subject: [PATCH] iw: version.sh: don't use git describe for versioning
+
+It will detect top-level git repositories like the Angstrom setup-scripts and break.
+
+Upstream-status: Unknown
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ version.sh | 16 +---------------
+ 1 files changed, 1 insertions(+), 15 deletions(-)
+
+diff --git a/version.sh b/version.sh
+index 3fb9f6d..e4a56cb 100755
+--- a/version.sh
++++ b/version.sh
+@@ -3,21 +3,7 @@
+ VERSION="3.2"
+ OUT="$1"
+
+-if head=`git rev-parse --verify HEAD 2>/dev/null`; then
+- git update-index --refresh --unmerged > /dev/null
+- descr=$(git describe)
+-
+- # on git builds check that the version number above
+- # is correct...
+- [ "${descr%%-*}" = "v$VERSION" ] || exit 2
+-
+- v="${descr#v}"
+- if git diff-index --name-only HEAD | read dummy ; then
+- v="$v"-dirty
+- fi
+-else
+- v="$VERSION"
+-fi
++v="$VERSION"
+
+ echo '#include "iw.h"' > "$OUT"
+ echo "const char iw_version[] = \"$v\";" >> "$OUT"
+--
+1.7.7.3
+
diff --git a/meta-oe/recipes-connectivity/iw/iw_3.2.bb b/meta-oe/recipes-connectivity/iw/iw_3.2.bb
index ba7afdd377..65e7c8f739 100644
--- a/meta-oe/recipes-connectivity/iw/iw_3.2.bb
+++ b/meta-oe/recipes-connectivity/iw/iw_3.2.bb
@@ -4,9 +4,13 @@ SECTION = "base"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
+PR = "r1"
+
DEPENDS = "libnl pkgconfig"
-SRC_URI = "http://wireless.kernel.org/download/iw/${P}.tar.bz2"
+SRC_URI = "http://wireless.kernel.org/download/iw/${P}.tar.bz2 \
+ file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
+ "
SRC_URI[md5sum] = "80615c972a287dcd50890735469b0d1c"
SRC_URI[sha256sum] = "370edabe6f73cc55be77a7502a3a25d23ec2aea900ae4ca3cec19d55bf8bdb12"