aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gnuradio
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-18 11:14:09 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-19 20:41:26 +0200
commit790355db870872419a19f12bfdd0df0d52f8ae7b (patch)
tree0ba253f3c1348c20fca772f922b1379287d8637f /meta-oe/recipes-connectivity/gnuradio
parentfee27f922acd35c5d57f112ef0e273ab85ebe308 (diff)
downloadmeta-openembedded-contrib-790355db870872419a19f12bfdd0df0d52f8ae7b.tar.gz
gnuradio: update to 3.4.0 and clean up
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gnuradio')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio.inc11
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch58
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch42
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb10
4 files changed, 112 insertions, 9 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc b/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc
index d114f89eac..3759e077b2 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio.inc
@@ -1,10 +1,11 @@
DESCRIPTION = "GNU Radio"
-URL = "http://gnuradio.org"
-SECTION = "apps"
-PRIORITY = "optional"
+HOMEPAGE = "http://gnuradio.org"
LICENSE = "GPLv3"
-DEPENDS = "uhd gsl guile-native fftwf python alsa-lib boost cppunit swig-native python-numpy"
-INC_PR = "r8"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "uhd virtual/libsdl gsl guile-native fftwf python alsa-lib boost cppunit swig-native python-numpy"
+
+INC_PR = "r0"
inherit distutils-base autotools pkgconfig
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch
new file mode 100644
index 0000000000..7caaf51e65
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch
@@ -0,0 +1,58 @@
+From a130153ae84d8bb5914879cef94df09f06825c10 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sat, 18 Jun 2011 11:25:36 +0200
+Subject: [PATCH] buildsys: don't add /usr/include and /usr/lib to configure tests for libusb
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ config/usrp_libusb.m4 | 13 -------------
+ 1 files changed, 0 insertions(+), 13 deletions(-)
+
+diff --git a/config/usrp_libusb.m4 b/config/usrp_libusb.m4
+index cc3410f..b421820 100644
+--- a/config/usrp_libusb.m4
++++ b/config/usrp_libusb.m4
+@@ -117,10 +117,6 @@ AC_DEFUN([USRP_LIBUSB], [
+ dnl configured to find this header.
+ AC_LANG_PUSH(C)
+ save_CPPFLAGS="$CPPFLAGS"
+- if test x$USB_INCLUDEDIR != x; then
+- USB_INCLUDES="-I$USB_INCLUDEDIR"
+- CPPFLAGS="$USB_INCLUDES"
+- fi
+ AC_MSG_CHECKING([$libusb_name for header $usb_header])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include "$usb_header"
+@@ -172,9 +168,6 @@ AC_DEFUN([USRP_LIBUSB], [
+ *)
+ AC_LANG_PUSH(C)
+ save_CPPFLAGS="$CPPFLAGS"
+- if test x$USB_INCLUDEDIR != x; then
+- CPPFLAGS="$USB_INCLUDES"
+- fi
+ save_LIBS="$LIBS"
+ LIBS="$USB_LIBS"
+ AC_MSG_CHECKING([$libusb_name for symbol usb_debug in library $usb_lib_name])
+@@ -217,9 +210,6 @@ AC_DEFUN([USRP_LIBUSB], [
+ dnl final error checking, mostly to create #define's
+ AC_LANG_PUSH(C)
+ save_CPPFLAGS="$CPPFLAGS"
+- if test x$USB_INCLUDEDIR != x; then
+- CPPFLAGS="$USB_INCLUDES"
+- fi
+ dnl Check for the header.
+ AC_CHECK_HEADERS([$usb_header], [], [libusbok=no])
+ CPPFLAGS="$save_CPPFLAGS"
+@@ -231,9 +221,6 @@ AC_DEFUN([USRP_LIBUSB], [
+ dnl check for the library (again)
+ AC_LANG_PUSH(C)
+ save_CPPFLAGS="$CPPFLAGS"
+- if test x$USB_INCLUDEDIR != x; then
+- CPPFLAGS="$USB_INCLUDES"
+- fi
+ save_LIBS="$LIBS"
+ LIBS="$USB_LIBS"
+ AC_CHECK_LIB([$usb_lib_name], [$usb_lib_func], [], [
+--
+1.6.6.1
+
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch
new file mode 100644
index 0000000000..e2f674b752
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch
@@ -0,0 +1,42 @@
+From 857c38eb8201e2a34b524fcabea21b1accbdb288 Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@opensdr.com>
+Date: Fri, 13 May 2011 12:26:14 -0400
+Subject: [PATCH] volk : Remove all traces of volk from configure for OE builds.
+
+Signed-off-by: Philip Balister <philip@opensdr.com>
+---
+ Makefile.common | 4 ++--
+ configure.ac | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.common b/Makefile.common
+index 20b8a78..aeda1dd 100644
+--- a/Makefile.common
++++ b/Makefile.common
+@@ -92,8 +92,8 @@ GRUEL_INCLUDES = @gruel_INCLUDES@
+ GRUEL_LA = @gruel_LA@
+
+ # How to link in the VOLK library from inside the tree
+-VOLK_INCLUDES = @volk_INCLUDES@
+-VOLK_LA = @volk_LA@
++#VOLK_INCLUDES = @volk_INCLUDES@
++#VOLK_LA = @volk_LA@
+
+ # How to link in the USRP library from inside the tree
+ USRP_INCLUDES = @usrp_INCLUDES@
+diff --git a/configure.ac b/configure.ac
+index 73ebbd6..e5cf7a2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -349,7 +349,7 @@ AC_ARG_ENABLE(
+
+ build_dirs="config"
+ GRC_GRUEL dnl must come first
+-GRC_VOLK
++dnl GRC_VOLK
+ GRC_GCELL
+ GRC_GNURADIO_CORE
+ GRC_USRP
+--
+1.7.3.4
+
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index 757a80136d..76c9424180 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -1,16 +1,18 @@
require gnuradio.inc
-PR = "${INC_PR}.1"
-PV = "3.3.0-${PR}+gitr${SRCREV}"
+PR = "${INC_PR}.0"
+PV = "3.4.0-${PR}+gitr${SRCREV}"
-SRCREV = "cdca1c917626f7c63f820da921a17187efc92cd5"
+SRCREV = "f53fef3d2bc39b2020b8bce3d88b43569dd16605"
# Make it easy to test against developer repos and branches
GIT_REPO = "gnuradio.git"
GIT_BRANCH = "next"
SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \
-"
+ file://0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch \
+ file://0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch \
+ "
S="${WORKDIR}/git"