aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-10 15:01:18 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-10 15:02:04 +0100
commit681b30a6ed830e47c8b77cc9a72cdc82c4ec2190 (patch)
treecb85e1ec21ef4ac653afa7327a27de4858fc6199 /meta-oe/recipes-connectivity/gateone
parent1e93fb3cb6d716ad811bd26154fdcec42195c360 (diff)
downloadmeta-openembedded-contrib-681b30a6ed830e47c8b77cc9a72cdc82c4ec2190.tar.gz
gateone: add avahi and systemd support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb22
1 files changed, 17 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index fdccadd550..1b87a029b2 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -2,15 +2,18 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
LICENSE = "AGPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=07d5a2790569bd3e3b422b69ccd43bec"
-PR = "r5"
+PR = "r6"
PV = "0.9"
-SRCREV = "031a85e8e24ae499e41e15b5077c33a4bd647bd3"
-SRC_URI = "git://github.com/liftoff/GateOne.git"
+SRCREV = "13836e34b70998cf59e3e5d8e2b9c90a60c26cc9"
+SRC_URI = "git://github.com/liftoff/GateOne.git \
+ file://gateone-avahi.service \
+ file://gateone.service \
+ "
S = "${WORKDIR}/git"
-inherit distutils
+inherit distutils systemd
do_configure_prepend() {
sed -i -e s:/opt:${D}${localstatedir}/lib: setup.py
@@ -18,9 +21,18 @@ do_configure_prepend() {
do_install_append() {
install -d ${D}${localstatedir}/log/${BPN}
+
+ install -m 0755 -d ${D}${base_libdir}/systemd/system
+ install -m 0644 ${WORKDIR}/gateone.service ${D}${base_libdir}/systemd/system/
+
+ install -m 0755 -d ${D}${sysconfdir}/avahi/services/
+ install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
}
-FILES_${PN} = "${localstatedir}"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE = "gateone.service"
+
+FILES_${PN} = "${localstatedir} ${base_libdir} ${sysconfdir}"
RDEPENDS_${PN} = "python-tornado \
python-datetime \
python-shell \