aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/connman
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2011-08-17 14:13:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-17 09:21:40 +0200
commit9e4fdee5789b36ffd4b6ad5452edb1ca8eeb4c5f (patch)
tree2cf32903a17d055ab1cf338efa9632cbf8a5f210 /meta-oe/recipes-connectivity/connman
parent7b1ed1f94a4dd44053b2f73990a729cd5aaf8ab2 (diff)
downloadmeta-openembedded-contrib-9e4fdee5789b36ffd4b6ad5452edb1ca8eeb4c5f.tar.gz
connman: conditionally enable wifi and bluetooth
Use DISTRO_FEATURES to conditionally depend and enable wifi and bluetooth. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/connman')
-rw-r--r--meta-oe/recipes-connectivity/connman/connman.inc5
-rw-r--r--meta-oe/recipes-connectivity/connman/connman_0.76.bb4
2 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/connman/connman.inc b/meta-oe/recipes-connectivity/connman/connman.inc
index 2652125526..eeccf50861 100644
--- a/meta-oe/recipes-connectivity/connman/connman.inc
+++ b/meta-oe/recipes-connectivity/connman/connman.inc
@@ -14,7 +14,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
file://src/main.c;beginline=1;endline=20;md5=4b55b550fa6b33cc2055ef30dd262b3e"
# we need to define the depends here, the dynamic stuff is too late
-DEPENDS = "wpa-supplicant dbus glib-2.0 ppp busybox dhcp resolvconf bluez4 iptables gnutls ntp"
+DEPENDS = "dbus glib-2.0 ppp busybox dhcp resolvconf iptables gnutls ntp \
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth','bluez4', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
+ "
EXTRA_OECONF += "\
ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
diff --git a/meta-oe/recipes-connectivity/connman/connman_0.76.bb b/meta-oe/recipes-connectivity/connman/connman_0.76.bb
index cb84caaff4..abae73a322 100644
--- a/meta-oe/recipes-connectivity/connman/connman_0.76.bb
+++ b/meta-oe/recipes-connectivity/connman/connman_0.76.bb
@@ -6,8 +6,8 @@ EXTRA_OECONF += "\
--enable-threads \
--enable-loopback \
--enable-ethernet \
- --enable-wifi \
- --enable-bluetooth \
+ ${@base_contains('DISTRO_FEATURES', 'wifi','--enable-wifi', '--disable-wifi', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
--enable-ofono \
--enable-tools \
--disable-polkit \