aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 14:26:01 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:37 -0800
commit9646fb8ced5a8eeb806b08ba0e97f359f866e8d3 (patch)
tree1b9e8597044973f70b498629423da0e2d515c899 /meta-oe/recipes-bsp
parent503a572e1420c650ea0279e3e7db1cb401239196 (diff)
downloadmeta-openembedded-contrib-9646fb8ced5a8eeb806b08ba0e97f359f866e8d3.tar.gz
efibootmgr: move to recipes-bsps
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb
new file mode 100644
index 0000000000..9cc62a9591
--- /dev/null
+++ b/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.15.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
+SUMMARY = "EFI Boot Manager"
+HOMEPAGE = "https://github.com/rhinstaller/efibootmgr"
+SECTION = "base"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+DEPENDS = "pciutils zlib efivar"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
+SRCREV = "5c14da22802576a99ebb854f7aa174f796f7b031"
+SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
+ "
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'"
+
+CFLAGS_append_toolchain-clang = " -Wno-error"
+do_install () {
+ install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr
+}
+
+CLEANBROKEN = "1"