aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorPeter Bergin <peter@berginkonsult.se>2022-10-31 15:47:02 +0100
committerKhem Raj <raj.khem@gmail.com>2023-01-08 13:55:20 -0800
commitbb31da87599853b2e5d4d4adc641a93edb22cd16 (patch)
tree897b8dc7d394cac9e41a863bbb9e1be9cf0d7aa0 /meta-oe/recipes-benchmark
parent31bbb228f06228c40fd2fec2b988031c6b1222df (diff)
downloadmeta-openembedded-contrib-bb31da87599853b2e5d4d4adc641a93edb22cd16.tar.gz
sysbench: Upgrade 0.4.12 -> 1.0.20
Use system cuncurrencykit and enable riscv Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch40
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb (renamed from meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb)18
2 files changed, 10 insertions, 48 deletions
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch b/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch
deleted file mode 100644
index d628e81b56..0000000000
--- a/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From c1ebf893e32a0a77e820484d48a903523fef7c1b Mon Sep 17 00:00:00 2001
-From: Vasily Tarasov <tarasov@vasily.name>
-Date: Fri, 10 Jun 2016 14:33:48 -0400
-Subject: [PATCH] Adding volatile modifier to tmp variable in memory test
-
-Issue explanation:
-
-./sysbench/sysbench --test=memory --num-threads=16 \
- --memory-block-size=268435456 \
- --memory-total-size=137438953472 \
- --memory-oper=read \
- --memory-access-mode=seq \
- --memory-scope=local run
-
-Without this commit the time to run the above command is 0.0004 seconds.
-With this commit the time is greater than 3 seconds. Essentially,
-without the volatile modifier, the compiler optimizes read access so
-that no real access happens.
-
-Upstream-Status: Backport [part of v1.0.0 https://github.com/akopytov/sysbench/commit/8753cb93be4c0b81a20b704ced91e7a422da52b1]
-
-(cherry picked from commit 8753cb93be4c0b81a20b704ced91e7a422da52b1)
-Signed-off-by: massimo toscanelli <massimo.toscanelli@leica-geosystems.com>
----
- sysbench/tests/memory/sb_memory.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sysbench/tests/memory/sb_memory.c b/sysbench/tests/memory/sb_memory.c
-index 2e8998f..7d22bb9 100644
---- a/sysbench/tests/memory/sb_memory.c
-+++ b/sysbench/tests/memory/sb_memory.c
-@@ -244,7 +244,7 @@ sb_request_t memory_get_request(int tid)
- int memory_execute_request(sb_request_t *sb_req, int thread_id)
- {
- sb_mem_request_t *mem_req = &sb_req->u.mem_request;
-- int tmp = 0;
-+ volatile int tmp = 0;
- int idx;
- int *buf, *end;
- log_msg_t msg;
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
index 4ac78fb8fd..098954af37 100644
--- a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
@@ -2,20 +2,22 @@ SUMMARY = "System performance benchmark"
HOMEPAGE = "http://github.com/akopytov/sysbench"
SECTION = "console/tests"
LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-inherit autotools
+DEPENDS = "libtool libaio luajit concurrencykit"
+
+inherit autotools-brokensep pkgconfig
# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
# Launchpad until the next release is available from Github.
-SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz \
- file://0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch \
- "
+SRC_URI = "git://github.com/akopytov/sysbench.git;protocol=https;branch=master"
+SRCREV = "ebf1c90da05dea94648165e4f149abc20c979557"
+
+S = "${WORKDIR}/git"
-SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
-SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"
+COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64|riscv32|riscv64).*-linux*"
-EXTRA_OECONF += "--enable-largefile"
+EXTRA_OECONF += "--enable-largefile --with-system-luajit --with-system-ck --without-gcc-arch"
PACKAGECONFIG ??= ""
PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
PACKAGECONFIG[mysql] = "--with-mysql \