aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-08-31 01:59:41 +0200
committerKhem Raj <raj.khem@gmail.com>2023-08-30 17:09:52 -0700
commit57b37873c5b79294c061a5c44321e58b5572182e (patch)
treefc65431b5383b5211115c8428c65800cdbfd1af6 /meta-oe/recipes-benchmark
parentd88ac90b627d4eb540ceb1a29b0c8de4e36224aa (diff)
downloadmeta-openembedded-contrib-57b37873c5b79294c061a5c44321e58b5572182e.tar.gz
sysbench: avoid -L/usr/lib32 and configure-unsafe QA issue
* when libdir isn't /usr/lib (e.g. /usr/lib32 with multilib), then m4/lib-prefix.m4 can add additional_libdir=\"$libdir\": dnl Potentially add $additional_libdir to $LDFLAGS. dnl But don't add it dnl 1. if it's the standard /usr/lib, dnl 2. if it's already present in $LDFLAGS, dnl 3. if it's /usr/local/lib and we are using GCC on Linux, dnl 4. if it doesn't exist as a directory. if test "X$additional_libdir" != "X/usr/$acl_libdirstem"; then this doesn't happen in regular builds because of condion 1. above * fixes: ERROR: QA Issue: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities. Rerun configure task after fixing this. [configure-unsafe] * drop libaio from DEPENDS as it's added by PACKAGECONFIG when enabled * I've also tried to drop brokensep as it was added in: https://git.openembedded.org/meta-openembedded/commit/?id=bb31da87599853b2e5d4d4adc641a93edb22cd16 https://github.com/openembedded/meta-openembedded/pull/632/commits/d2265dbacdb9e7bd7d6e4a9f1a2b3cc1633fb328 without any explation why brokensep was needed for 1.0.20 (while it wasn't used in 0.4.12 version) and it looks like luajit detection fails without broken sep and build with internal luajit then fails with: ./lua/internal/sysbench.lua.h:1:17: error: expected '=', ',', ';', 'asm' or '__attribute__' before '/' token 1 | unsigned char __/__/__/__/git/src/lua/internal/sysbench_lua[] = | ^ but I'll leave this to someone actually using sysbench Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
index 945e2c3274..11e33fec55 100644
--- a/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench_1.0.20.bb
@@ -4,7 +4,7 @@ SECTION = "console/tests"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "libtool libaio luajit concurrencykit"
+DEPENDS = "libtool luajit concurrencykit"
inherit autotools-brokensep pkgconfig
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git"
COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64).*-linux*"
-EXTRA_OECONF += "--enable-largefile --with-system-luajit --with-system-ck --without-gcc-arch"
+EXTRA_OECONF += "--enable-largefile --with-system-luajit --with-system-ck --without-gcc-arch --with-lib-prefix=no"
PACKAGECONFIG ??= ""
PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
PACKAGECONFIG[mysql] = "--with-mysql \