aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-12 11:44:04 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:41 -0700
commit4cde452b197b09272131bff98c0c98f49267b9cc (patch)
treeedef0d35d411c5030f966f2b9644624f3341716b /meta-oe/recipes-benchmark
parentc03a543d93d955effe603257a7f3782970e95271 (diff)
downloadmeta-openembedded-contrib-4cde452b197b09272131bff98c0c98f49267b9cc.tar.gz
glmark2: Fix build with gcc12
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch24
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch b/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
new file mode 100644
index 0000000000..959a18e5eb
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
@@ -0,0 +1,24 @@
+From 45cb02332b38b2059e7e44369c3d8684492a7def Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 12 Apr 2022 11:41:41 -0700
+Subject: [PATCH] libmatrix: Include missing <utility> header
+
+Fixes build with gcc12
+| ../git/src/libmatrix/program.h:43:21: error: 'exchange' is not a member of 'std' | 43 | ready_(std::exchange(shader.ready_, false)), | | ^~~~~~~~
+
+Upstream-Status: Submitted [https://github.com/glmark2/glmark2/pull/174]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/libmatrix/program.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/libmatrix/program.h
++++ b/src/libmatrix/program.h
+@@ -13,6 +13,7 @@
+ #define PROGRAM_H_
+
+ #include <string>
++#include <utility>
+ #include <vector>
+ #include <map>
+ #include "mat.h"
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 47d927397c..1406f68b05 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -17,6 +17,7 @@ SRC_URI = " \
git://github.com/glmark2/glmark2.git;protocol=https;branch=master \
file://0001-fix-dispmanx-build.patch \
file://0002-run-dispmanx-fullscreen.patch \
+ file://0001-libmatrix-Include-missing-utility-header.patch \
"
SRCREV = "0858b450cd88c84a15b99dda9698d44e7f7e8c70"