aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorDiego Rondini <diego.ml@zoho.com>2014-05-08 17:28:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-15 12:30:18 +0200
commite6af2100727346a1fcabbbec4569601889726416 (patch)
tree72e91afebc5cfc62822c4652f9cfa781b48da609 /meta-oe/recipes-benchmark
parent6bb0c0de3f5284ba506211362227d34e02ae5553 (diff)
downloadmeta-openembedded-contrib-e6af2100727346a1fcabbbec4569601889726416.tar.gz
glmark2: update to version 2014.03
Update glmark2 receipe to upstream version 2014.03. The configure step has changed and instead of using "--enable-stuff" syntax, now the syntax is "--with-flavors=flavor1,flavor2". Thanks to Paul Eggleton for the help on how to deal with that: https://lists.yoctoproject.org/pipermail/yocto/2014-April/019328.html Signed-off-by: Diego Rondini <diego.ml@zoho.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb (renamed from meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb)19
1 files changed, 15 insertions, 4 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb
index 031e3b3d4d..3ff0449bd6 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_2014.03.bb
@@ -12,12 +12,23 @@ DEPENDS = "libpng12 jpeg"
SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
-SRC_URI[md5sum] = "4f306664aa3886fa0cf93853603603f8"
-SRC_URI[sha256sum] = "bea6f9de2cdce376195bd91e4a2fdfdf80bf3e480abff8e05b90a6458c1deb47"
+SRC_URI[md5sum] = "739859cf57d4c8a23452c43e84f66e56"
+SRC_URI[sha256sum] = "bded41aaf918ce062d9b81e42cc5be943e6a80bc4ff9d046983b96102c3df6b5"
inherit waf pkgconfig
PACKAGECONFIG ?= "gl gles2"
-PACKAGECONFIG[gl] = "--enable-gl,,virtual/libgl"
-PACKAGECONFIG[gles2] = "--enable-glesv2,,virtual/libgles2"
+PACKAGECONFIG[gl] = ",,virtual/libgl"
+PACKAGECONFIG[gles2] = ",,virtual/libgles2"
+
+python __anonymous() {
+ packageconfig = (d.getVar("PACKAGECONFIG", True) or "").split()
+ flavors = []
+ if "gles2" in packageconfig:
+ flavors.append("x11-glesv2")
+ if "gl" in packageconfig:
+ flavors.append("x11-gl")
+ if flavors:
+ d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
+}