aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-benchmark
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb10
-rw-r--r--meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb10
-rw-r--r--meta-oe/recipes-benchmark/dbench/dbench_4.0.bb6
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_2.0.5.bb6
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3_263.bb40
-rw-r--r--meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb18
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb42
-rw-r--r--meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb14
-rw-r--r--meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb8
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb4
10 files changed, 79 insertions, 79 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
index 7a6b798bdb..529be8e459 100644
--- a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
+++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \
file://gcc-4.3-fixes.patch \
- "
+"
SRC_URI[md5sum] = "77a1ba78f37bdd7f024b67e1e36ad151"
SRC_URI[sha256sum] = "c674f1182f4c20f1e6d038feceb0a6617fc3e7658dfbbac89396043b49612a26"
@@ -17,10 +17,10 @@ EXES = "bonnie++ zcav"
TARGET_CC_ARCH += "${LDFLAGS}"
do_install () {
- install -d ${D}/bin
- install -d ${D}/sbin
- install -m 0755 ${EXES} ${D}/sbin
- install -m 0755 ${SCRIPTS} ${D}/bin
+ install -d ${D}/bin
+ install -d ${D}/sbin
+ install -m 0755 ${EXES} ${D}/sbin
+ install -m 0755 ${SCRIPTS} ${D}/bin
}
PACKAGES =+ "bonnie-scripts"
diff --git a/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb
index 5bc3129df7..25b6388886 100644
--- a/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb
+++ b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb
@@ -17,13 +17,13 @@ SRC_URI[ssvb.sha256sum] = "bfddd3226a499ffdf71bb58c05ccdc6dac5bb2c2c3bdb10ac610e
S = "${WORKDIR}"
do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn
- ${CC} ${CFLAGS} ${LDFLAGS} ssvb-cpuburn-a8.S -o burn-neona8
+ ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn
+ ${CC} ${CFLAGS} ${LDFLAGS} ssvb-cpuburn-a8.S -o burn-neona8
}
do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${S}/burn ${D}${bindir}/burn-neon
- install -m 0755 ${S}/burn-neona8 ${D}${bindir}/
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/burn ${D}${bindir}/burn-neon
+ install -m 0755 ${S}/burn-neona8 ${D}${bindir}/
}
diff --git a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
index b61eb910b0..5afeda2da0 100644
--- a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
+++ b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
@@ -8,9 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "popt"
SRC_URI = "\
- http://samba.org/ftp/tridge/dbench/dbench-${PV}.tar.gz \
- file://destdir.patch \
- file://makefile.patch"
+ http://samba.org/ftp/tridge/dbench/dbench-${PV}.tar.gz \
+ file://destdir.patch \
+ file://makefile.patch"
inherit autotools
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
index 4c086c805f..e21ab6df83 100644
--- a/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
@@ -21,7 +21,7 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
do_install() {
- oe_runmake install DESTDIR=${D} bindir=${bindir} mandir=${mandir}
- install -d ${D}/${docdir}/${PN}
- cp -a ${S}/examples ${D}/${docdir}/${PN}/
+ oe_runmake install DESTDIR=${D} bindir=${bindir} mandir=${mandir}
+ install -d ${D}/${docdir}/${PN}
+ cp -a ${S}/examples ${D}/${docdir}/${PN}/
}
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb b/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
index c1aa7fb3eb..b0e0dad449 100644
--- a/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://iozone.c;beginline=237;endline=241;md5=ab42a6185fd044
SRC_URI = "http://www.iozone.org/src/current/iozone3_263.tar \
- file://copyright.txt \
- file://fileop-arm.patch \
- "
+ file://copyright.txt \
+ file://fileop-arm.patch \
+"
SRC_URI[md5sum] = "44fd88df361ec4508e10c8d6615245fa"
SRC_URI[sha256sum] = "920fde1a3843539570e2df4aa611e74df102e52d363c5973d5a9d15bdf976461"
@@ -23,26 +23,26 @@ EXTRA_OEMAKE = "linux CC='${CC}'"
TARGET_CC_ARCH += "${LDFLAGS}"
do_install() {
- install -d ${D}${bindir} \
- ${D}${mandir}/man1 \
- ${D}${datadir}/doc/${PN}/examples
+ install -d ${D}${bindir} \
+ ${D}${mandir}/man1 \
+ ${D}${datadir}/doc/${PN}/examples
- install -m 0755 ${S}/iozone ${D}${bindir}
- install -m 0755 ${S}/fileop ${D}${bindir}
- install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
- install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${PN}/
+ install -m 0755 ${S}/iozone ${D}${bindir}
+ install -m 0755 ${S}/fileop ${D}${bindir}
+ install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
+ install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${PN}/
- install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${PN}/examples
- install -m 0644 ${S}/client_list ${D}${datadir}/doc/${PN}/examples
- install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${PN}/examples
+ install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${PN}/examples
+ install -m 0644 ${S}/client_list ${D}${datadir}/doc/${PN}/examples
+ install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${PN}/examples
- install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${PN}/examples
- install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${PN}/examples
- install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${PN}/examples
+ install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${PN}/examples
+ install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${PN}/examples
+ install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${PN}/examples
- install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${PN}/
- install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${PN}/
- install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${PN}/
}
FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
@@ -66,7 +66,7 @@ FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
#
# Marcin,
#
-# Re-distribution is permitted as long as the copyright is
+# Re-distribution is permitted as long as the copyright is
# maintained and the source code is not changed. I do not
# see a problem with your mods to enable fileop for Linux-arm,
# as these mods have been returned to the Iozone folks,
diff --git a/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb b/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
index bd8bac126b..8107701551 100644
--- a/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
+++ b/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
@@ -5,7 +5,7 @@ LICENSE = "NewBSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
SRC_URI = " \
- ${SOURCEFORGE_MIRROR}/iperf/iperf-${PV}.tar.gz \
+ ${SOURCEFORGE_MIRROR}/iperf/iperf-${PV}.tar.gz \
file://000-Iperf_Fix-CPU-Usage.diff \
file://001-cast-to-max_size_t-instead-of-int.patch \
file://003-fix-hyphen-used-as-minus-sign.patch \
@@ -15,7 +15,7 @@ SRC_URI = " \
file://007-iperf-reporter-deadlock.patch \
file://008-numofreport.patch \
file://009-delayloop.patch \
- "
+"
SRC_URI[md5sum] = "8c5bc14cc2ea55f18f22afe3c23e3dcb"
@@ -28,19 +28,19 @@ S="${WORKDIR}/iperf-${PV}"
EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
do_configure() {
- export ac_cv_func_malloc_0_nonnull=yes
- gnu-configize
- oe_runconf
+ export ac_cv_func_malloc_0_nonnull=yes
+ gnu-configize
+ oe_runconf
}
do_compile() {
- cd ${WORKDIR}/iperf-${PV}
- oe_runmake
+ cd ${WORKDIR}/iperf-${PV}
+ oe_runmake
}
do_install() {
- cd ${WORKDIR}/iperf-${PV}/src
- oe_runmake DESTDIR=${D} install
+ cd ${WORKDIR}/iperf-${PV}/src
+ oe_runmake DESTDIR=${D} install
}
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index 25d0a671d1..31a1109045 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -15,7 +15,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://update-results-script.patch \
file://obey-ranlib.patch \
file://update-config-script.patch \
- "
+"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -24,32 +24,32 @@ EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB}" CFLAGS="${CFLAGS}" \
TARGET="${TARGET_OS}" BASE="${prefix}" MANDIR="${mandir}"'
do_configure() {
- :
+ :
}
do_compile () {
- . ${CONFIG_SITE}
- if [ X"$ac_cv_uint" = X"yes" ]; then
- CFLAGS="${CFLAGS} -DHAVE_uint"
- fi
- install -d ${S}/bin/${TARGET_SYS}
- oe_runmake -C src
+ . ${CONFIG_SITE}
+ if [ X"$ac_cv_uint" = X"yes" ]; then
+ CFLAGS="${CFLAGS} -DHAVE_uint"
+ fi
+ install -d ${S}/bin/${TARGET_SYS}
+ oe_runmake -C src
}
do_install () {
- install -d ${D}${localstatedir}/run/lmbench \
- ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \
- ${D}${datadir}/lmbench/scripts
- oe_runmake 'BASE=${D}${prefix}' \
- -C src install
- mv ${D}${bindir}/line ${D}${bindir}/lm_line
- install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
- sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
- -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' \
- -e 's,^CONFIG=.*$,CONFIG=$SHAREDIR/`$SCRIPTSDIR/config`,;' \
- ${D}${bindir}/lmbench-run
- install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
- install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
+ install -d ${D}${localstatedir}/run/lmbench \
+ ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \
+ ${D}${datadir}/lmbench/scripts
+ oe_runmake 'BASE=${D}${prefix}' \
+ -C src install
+ mv ${D}${bindir}/line ${D}${bindir}/lm_line
+ install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
+ sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
+ -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' \
+ -e 's,^CONFIG=.*$,CONFIG=$SHAREDIR/`$SCRIPTSDIR/config`,;' \
+ ${D}${bindir}/lmbench-run
+ install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
+ install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
}
RDEPENDS_${PN} = "debianutils"
diff --git a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
index f220553bf5..5273078d53 100644
--- a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
+++ b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
@@ -12,14 +12,14 @@ SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38"
SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6"
do_compile () {
- echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
- echo '${CC} ${LDFLAGS}' > conf-ld
- oe_runmake
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
}
do_install () {
- install -d ${D}${bindir}
- install -d ${D}${mandir}/man8
- install -m 0755 memtester ${D}${bindir}/
- install -m 0755 memtester.8 ${D}${mandir}/man8/
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
}
diff --git a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
index 8dd289bc67..37f3e46a7e 100644
--- a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
+++ b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
@@ -14,11 +14,11 @@ SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed
TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
do_compile() {
- oe_runmake
+ oe_runmake
}
do_install () {
- install -d ${D}${bindir}
- install -m 0644 NNET.DAT ${D}${bindir}/
- install -m 0755 nbench ${D}${bindir}/
+ install -d ${D}${bindir}
+ install -m 0644 NNET.DAT ${D}${bindir}/
+ install -m 0755 nbench ${D}${bindir}/
}
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
index 236b91393c..fd04b06671 100644
--- a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
@@ -9,7 +9,7 @@ SRC_URI = "\
http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${P}.tar.gz \
file://tiobench-makefile.patch \
file://avoid-glibc-clashes.patch \
- "
+"
SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
@@ -25,4 +25,4 @@ RDEPENDS_${PN} = "\
perl-module-getopt-long \
perl-module-overload \
perl-module-strict \
- "
+"