aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-03-18 13:28:22 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-23 21:49:02 +0100
commit3a41db396dcf787a2167dad101cd2ebf084c5ee0 (patch)
treebdd4062363f71432e3fc56fd0243c5e080beb6d1 /meta-oe/recipes-benchmark
parentdee876f0e5a6412ba3e6bd7ab778761bd6491850 (diff)
downloadmeta-openembedded-contrib-3a41db396dcf787a2167dad101cd2ebf084c5ee0.tar.gz
glmark2: Rework recipe to use the 'waf' class
This removes the duplicated code and uses the OE-Core waf class. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb14
1 files changed, 1 insertions, 13 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
index 9edee149f5..031e3b3d4d 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
@@ -15,21 +15,9 @@ SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
SRC_URI[md5sum] = "4f306664aa3886fa0cf93853603603f8"
SRC_URI[sha256sum] = "bea6f9de2cdce376195bd91e4a2fdfdf80bf3e480abff8e05b90a6458c1deb47"
-inherit pkgconfig
+inherit waf pkgconfig
PACKAGECONFIG ?= "gl gles2"
PACKAGECONFIG[gl] = "--enable-gl,,virtual/libgl"
PACKAGECONFIG[gles2] = "--enable-glesv2,,virtual/libgles2"
-
-do_configure() {
- ./waf configure --prefix=${prefix} ${EXTRA_OECONF}
-}
-
-do_compile() {
- ./waf build ${PARALLEL_MAKE}
-}
-
-do_install() {
- ./waf install --destdir=${D}
-}