aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorDiego Rondini <diego.ml@zoho.com>2013-06-18 12:07:41 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-27 18:52:23 +0200
commit05270e3741cc5fadaa1359d3f65855bbea7b6e56 (patch)
tree88d806b07092f3bcee2427c7024b5dda84d19576 /meta-oe/recipes-benchmark
parent9bdae6db4c39a49bec6f521454703e950a151bb5 (diff)
downloadmeta-openembedded-contrib-05270e3741cc5fadaa1359d3f65855bbea7b6e56.tar.gz
glmark2: Add recipe for glmark2
Add a recipe for glmark2, which is an OpenGL 2.0 / OpenGL ES 2.0 benchmark. Signed-off-by: Diego Rondini <diego.ml@zoho.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
new file mode 100644
index 0000000000..b5d483c088
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_2012.12.bb
@@ -0,0 +1,35 @@
+SUMMARY = "OpenGL (ES) 2.0 benchmark"
+DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. \
+It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0."
+HOMEPAGE = "https://launchpad.net/glmark2"
+BUGTRACKER = "https://bugs.launchpad.net/glmark2"
+
+LICENSE = "GPLv3+ & SGIv1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
+
+DEPENDS = "libpng12"
+
+SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "4f306664aa3886fa0cf93853603603f8"
+SRC_URI[sha256sum] = "bea6f9de2cdce376195bd91e4a2fdfdf80bf3e480abff8e05b90a6458c1deb47"
+
+inherit pkgconfig
+
+PACKAGECONFIG ?= "gl gles2"
+
+PACKAGECONFIG[gl] = "--enable-gl,,virtual/libgl"
+PACKAGECONFIG[gles2] = "--enable-glesv2,,virtual/libgles2"
+
+do_configure() {
+ ./waf configure --prefix=${prefix} ${EXTRA_OECONF}
+}
+
+do_compile() {
+ ./waf build ${PARALLEL_MAKE}
+}
+
+do_install() {
+ ./waf install --destdir=${D}
+}