aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2019-08-04 22:36:49 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-05 00:38:49 -0700
commitbb781ebf2f052305e2f16b56540099080488f1d3 (patch)
treea0406a5e1b91f2821d14d101c5a4db9c53bf3862 /meta-oe/recipes-benchmark
parent7202dc267583c28e5617b8d3b4674f3e54f267b5 (diff)
downloadmeta-openembedded-contrib-bb781ebf2f052305e2f16b56540099080488f1d3.tar.gz
fio: fix first direct IO errored when ioengine is splice
backport an fio upstream patch to fix "first direct IO errored" when we specify -ioengine=spice Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/fio/files/0001-engines-splice-remove-buggy-mem_align-set.patch43
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.15.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/files/0001-engines-splice-remove-buggy-mem_align-set.patch b/meta-oe/recipes-benchmark/fio/files/0001-engines-splice-remove-buggy-mem_align-set.patch
new file mode 100644
index 0000000000..cb18032d24
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/files/0001-engines-splice-remove-buggy-mem_align-set.patch
@@ -0,0 +1,43 @@
+From 8ca8a05d92fa799fe93a6edc27b058802211fddc Mon Sep 17 00:00:00 2001
+From: Jens Axboe <axboe@kernel.dk>
+Date: Sat, 3 Aug 2019 08:33:24 -0600
+Subject: [PATCH] engines/splice: remove buggy ->mem_align set
+
+Two things wrong here:
+
+1) We align buffers by default, so no need for splice to do anything
+ extra.
+2) ->mem_align is not a true/false setting, it's the alignment itself.
+ Hence the current setting to 1 is just buggy.
+
+Upstream-Status: Backport [https://github.com/axboe/fio/commit/8ca8a05d92fa799fe93a6edc27b058802211fddc]
+
+Fixes: https://github.com/axboe/fio/issues/810
+Reported-by: Sitsofe Wheeler <sitsofe@yahoo.com>
+Signed-off-by: Jens Axboe <axboe@kernel.dk>
+Signed-off-by: Liwei Song <liwei.song@windriver.com>
+---
+ engines/splice.c | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/engines/splice.c b/engines/splice.c
+index feb764feb2f4..6fc36bb6f154 100644
+--- a/engines/splice.c
++++ b/engines/splice.c
+@@ -278,13 +278,6 @@ static int fio_spliceio_init(struct thread_data *td)
+ */
+ sd->vmsplice_to_user_map = 1;
+
+- /*
+- * And if vmsplice_to_user works, we definitely need aligned
+- * buffers. Just set ->odirect to force that.
+- */
+- if (td_read(td))
+- td->o.mem_align = 1;
+-
+ td->io_ops_data = sd;
+ return 0;
+ }
+--
+2.22.0
+
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.15.bb b/meta-oe/recipes-benchmark/fio/fio_3.15.bb
index c44075cdbe..f91a7f81d6 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.15.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.15.bb
@@ -25,6 +25,7 @@ PACKAGECONFIG[numa] = ",--disable-numa,numactl"
SRCREV = "01bf5128d0581e267383f280c6a1dcd26517240f"
SRC_URI = "git://git.kernel.dk/fio.git \
file://0001-update-the-interpreter-paths.patch \
+ file://0001-engines-splice-remove-buggy-mem_align-set.patch \
"
S = "${WORKDIR}/git"