aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-03-10 15:47:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:22 +0100
commitca5d383441f2d2eceb608b864b28b26cb4f70f53 (patch)
tree2c81c19b3c4640c9a89cb2818f70d82370f5815b /meta-oe/recipes-benchmark
parent6abfe21a2aaf5daa9ddca36fcd36c3f65febb230 (diff)
downloadmeta-openembedded-contrib-ca5d383441f2d2eceb608b864b28b26cb4f70f53.tar.gz
tinymembench: add initial recipe
Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb
new file mode 100644
index 0000000000..ae7887d3c6
--- /dev/null
+++ b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
+peak bandwidth of sequential memory accesses and the latency of random memory \
+accesses. Bandwidth is measured by running different assembly code for the \
+aligned memory blocks and attempting different prefetch strategies"
+HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
+
+PV = "0.3.9+git${SRCPV}"
+
+SRCREV = "95e68477588d41187b2d2e52ecf6be0e7eb06b8d"
+SRC_URI = "git://github.com/ssvb/tinymembench.git"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m755 tinymembench ${D}${bindir}/
+}