aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-08-08 11:39:54 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:57 +0200
commitc29c7ed7642c9e58a8e46f24a3d29e9dfed7da5a (patch)
tree195f6e16c5b53edbe8b7a5cf92af90cf6cd83bf0 /meta-oe/recipes-benchmark
parent9405f930b2cb0a1a260d0b7bfdc0ac0a7c8cc346 (diff)
downloadmeta-openembedded-contrib-c29c7ed7642c9e58a8e46f24a3d29e9dfed7da5a.tar.gz
glmark2: Fix gcc 6 configure error
Remove the un-necessary check for sqrt and avoid a gcc 6 configure error. Upstream-Status: Submitted [Pull request: a39907dd19726b2df3bac29a4bdc59d1bd0922a1] Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch13
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb5
2 files changed, 15 insertions, 3 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch
new file mode 100644
index 0000000000..fde82381d5
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch
@@ -0,0 +1,13 @@
+Index: git/wscript
+===================================================================
+--- git.orig/wscript 2016-07-29 13:15:44.954249796 -0500
++++ git/wscript 2016-07-29 15:52:06.196768865 -0500
+@@ -90,7 +90,7 @@
+ ctx.check_cxx(lib = lib, uselib_store = uselib)
+
+ # Check required functions
+- req_funcs = [('memset', 'string.h', []) ,('sqrt', 'math.h', ['m'])]
++ req_funcs = [('memset', 'string.h', [])]
+ for func, header, uselib in req_funcs:
+ ctx.check_cxx(function_name = func, header_name = header,
+ uselib = uselib, mandatory = True)
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 9c5ef1810d..18267e96f7 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -14,7 +14,8 @@ PV = "2014.03+${SRCPV}"
SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
- file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch"
+ file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
+ file://Fix-configure-for-sqrt-check.patch"
SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"
S = "${WORKDIR}/git"
@@ -51,5 +52,3 @@ python __anonymous() {
d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
}
-# http://errors.yoctoproject.org/Errors/Details/68626/
-PNBLACKLIST[glmark2] ?= "BROKEN: fails to build with gcc-6"