aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2016-08-25 09:41:32 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:30:50 +0200
commitbf918d5384a062f99ee5b775a319cde0b06e77bf (patch)
tree23a26ee4edd26a83bb518b101b24697aeb6c534a /meta-oe/recipes-benchmark
parentaedcb852ed7ec127dbb4c7cd7655d11f72e0b712 (diff)
downloadmeta-openembedded-contrib-bf918d5384a062f99ee5b775a319cde0b06e77bf.tar.gz
libhugetlbfs: add libhugetlbfs-perl to RDEPENDS
* Add libhugetlbfs-perl to RDEPENDS for libhugetlbfs as some perl scripts in package libhugetlbfs depend on the perl module provided by libhugetlbfs-perl * Update the perl module install folder to $(LIBDIR64)/perl/${@get_perl_version(d)}/TLBC such as /usr/lib64/perl/5.22.1/TLBC/OpCollect.pm otherwise the perl scripts can't find the perl module as below: Can't locate TLBC/OpCollect.pm in @INC (you may need to install the TLBC::OpCollect module) (@INC contains: /usr/bin /etc/perl /usr/lib64/perl/site_perl/5.22.1/ /usr/lib64/perl/site_perl/5.22.1 /usr/lib64/perl/vendor_perl/5.22.1/ /usr/lib64/perl/vendor_perl/5.22.1 /usr/lib64/perl/5.22.1/ /usr/lib64/perl/5.22.1 /usr/local/lib/site_perl .) at /usr/bin/cpupcstat line 12. BEGIN failed--compilation aborted at /usr/bin/cpupcstat line 12. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index accbffdfd7..301b5505d9 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -4,7 +4,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "sysfsutils perl"
-RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource"
+RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource ${PN}-perl"
RDEPENDS_${PN}-tests += "bash"
PV = "2.19"
@@ -37,6 +37,7 @@ CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0
TARGET_CC_ARCH += "${LDFLAGS}"
#The CUSTOM_LDSCRIPTS doesn't work with the gold linker
+inherit cpan-base
do_configure() {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
@@ -44,6 +45,11 @@ do_configure() {
# fixup perl module directory hardcoded to perl5
sed -i 's/perl5/perl/g' Makefile
+
+ # fixup to install perl module under $(LIBDIR)/perl/${@get_perl_version(d)}/TLBC
+ # to avoid below error
+ # Can't locate TLBC/OpCollect.pm in @INC
+ sed -i '/^PMDIR/ s:perl:perl/${@get_perl_version(d)}:g' Makefile
}
do_install() {