aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-11-08 00:49:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:38:30 +0100
commit913d1ea5d1b6684f24566acf96b4930b678daf97 (patch)
tree5a1faf170dab761568547d1633648ae0a44155e0 /meta-oe/recipes-benchmark
parent06a1221a310364550e3662b16c2a3c5a2ca297a2 (diff)
downloadmeta-openembedded-contrib-913d1ea5d1b6684f24566acf96b4930b678daf97.tar.gz
glmark: update to latest sources
With mesa 13.0.0 glmark-es2 crashed at the terrain part. This bug was fixed in the latest commit. See further details at [1]. [1] https://github.com/glmark2/glmark2/issues/25 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch27
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch61
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch6
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb14
4 files changed, 10 insertions, 98 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch
deleted file mode 100644
index 00eb2ed733..0000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 3fb9b6aeed2e2758239e59ba9ba1ca98535fe510 Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Fri, 19 Aug 2016 15:08:44 +0000
-Subject: [PATCH] Fix build error due missing space before macro
-Organization: O.S. Systems Software LTDA.
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- src/native-state-x11.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/native-state-x11.cpp b/src/native-state-x11.cpp
-index 3b66b77..3c1703b 100644
---- a/src/native-state-x11.cpp
-+++ b/src/native-state-x11.cpp
-@@ -60,7 +60,7 @@ NativeStateX11::display()
- bool
- NativeStateX11::create_window(WindowProperties const& properties)
- {
-- static const char *win_name("glmark2 "GLMARK_VERSION);
-+ static const char *win_name("glmark2 " GLMARK_VERSION);
-
- if (!xdpy_) {
- Log::error("Error: X11 Display has not been initialized!\n");
---
-2.1.4
-
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch
deleted file mode 100644
index 7a25de7908..0000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Index: git/src/image-reader.cpp
-===================================================================
---- git.orig/src/image-reader.cpp 2016-07-29 16:17:51.000000000 -0500
-+++ git/src/image-reader.cpp 2016-07-29 16:18:43.000000000 -0500
-@@ -120,7 +120,7 @@
-
- Log::debug("Reading PNG file %s\n", filename.c_str());
-
-- const std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
-+ const std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
- if (!(*is_ptr)) {
- Log::error("Cannot open file %s!\n", filename.c_str());
- return false;
-Index: git/src/libmatrix/shader-source.cc
-===================================================================
---- git.orig/src/libmatrix/shader-source.cc 2016-07-29 16:18:14.000000000 -0500
-+++ git/src/libmatrix/shader-source.cc 2016-07-29 16:18:43.000000000 -0500
-@@ -34,7 +34,7 @@
- bool
- ShaderSource::load_file(const std::string& filename, std::string& str)
- {
-- std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
-+ std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
- std::istream& inputFile(*is_ptr);
-
- if (!inputFile)
-Index: git/src/model.cpp
-===================================================================
---- git.orig/src/model.cpp 2016-07-29 16:18:00.000000000 -0500
-+++ git/src/model.cpp 2016-07-29 16:18:43.000000000 -0500
-@@ -361,7 +361,7 @@
-
- Log::debug("Loading model from 3ds file '%s'\n", filename.c_str());
-
-- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
-+ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
- std::istream& input_file(*input_file_ptr);
-
- if (!input_file) {
-@@ -681,7 +681,7 @@
- {
- Log::debug("Loading model from obj file '%s'\n", filename.c_str());
-
-- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
-+ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
- std::istream& inputFile(*input_file_ptr);
- if (!inputFile)
- {
-Index: git/src/scene-jellyfish.cpp
-===================================================================
---- git.orig/src/scene-jellyfish.cpp 2016-07-29 16:18:08.000000000 -0500
-+++ git/src/scene-jellyfish.cpp 2016-07-29 16:18:43.000000000 -0500
-@@ -272,7 +272,7 @@
- {
- Log::debug("Loading model from file '%s'\n", filename.c_str());
-
-- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
-+ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
- std::istream& inputFile(*input_file_ptr);
- if (!inputFile)
- {
diff --git a/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch b/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch
index ff13329ae5..72b8debe56 100644
--- a/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch
+++ b/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch
@@ -18,9 +18,9 @@ index cab62a3..e7eaed0 100644
--- a/wscript
+++ b/wscript
@@ -121,13 +121,17 @@ def configure(ctx):
- ('mirclient','mirclient', '0.13', list_contains(Options.options.flavors, 'mir')),
- ('wayland-client','wayland-client', None, list_contains(Options.options.flavors, 'wayland')),
- ('wayland-egl','wayland-egl', None, list_contains(Options.options.flavors, 'wayland'))]
+ ('mirclient','mirclient', '0.13', list_contains(ctx.options.flavors, 'mir')),
+ ('wayland-client','wayland-client', None, list_contains(ctx.options.flavors, 'wayland')),
+ ('wayland-egl','wayland-egl', None, list_contains(ctx.options.flavors, 'wayland'))]
- for (pkg, uselib, atleast, mandatory) in opt_pkgs:
+ for (pkg, uselib, atleast, check) in opt_pkgs:
+ # Check packages required by the flavors
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index a2558a72a0..e8ccf3799c 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -12,13 +12,13 @@ DEPENDS = "libpng12 jpeg"
PV = "2014.03+${SRCPV}"
-SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
- file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
- file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
- file://Fix-build-error-due-missing-space-before-macro.patch \
- file://Fix-configure-for-sqrt-check.patch \
- file://Fix-deprecated-declarations.patch"
-SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"
+SRC_URI = " \
+ git://github.com/glmark2/glmark2.git;protocol=https \
+ file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
+ file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
+ file://Fix-configure-for-sqrt-check.patch \
+"
+SRCREV = "f413c5b423250b4fde8f95639ad368d5b02c5b9b"
S = "${WORKDIR}/git"