aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-12-14 12:54:17 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:36:56 +0100
commit253c292d0edbff68b520f7c0b8ee04fefa1cffb6 (patch)
tree95cc94d26b08b1f8818a1cc5ffdd8447baed8e02 /meta-oe/recipes-benchmark
parent58739d4a7986f14b4776ef1173a2d02778cfafdf (diff)
downloadmeta-openembedded-contrib-253c292d0edbff68b520f7c0b8ee04fefa1cffb6.tar.gz
phoronix-test-suite: uprev it to 6.0.1
1. inherit systemd and move the systemd unit files to correct dir 2. inherit allarch 3. add bash/python to RDEDEPENDS Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb (renamed from meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_5.2.1.bb)17
1 files changed, 14 insertions, 3 deletions
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_5.2.1.bb b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb
index ef9f7352d5..5acfbf1bb5 100644
--- a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_5.2.1.bb
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_6.0.1.bb
@@ -6,19 +6,30 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SECTION = "console/tests"
SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
-SRC_URI[md5sum] = "51e52d883710dc516c5494bd1c377219"
-SRC_URI[sha256sum] = "1186f460691e2fe7a07df5edb8d8ed1ac0c65327512e646da2b2e3a60dda6cd9"
+SRC_URI[md5sum] = "c3b26fcc57a3a253e558f759fdc1089f"
+SRC_URI[sha256sum] = "27add54f4ecb464549de580cece84b4a4945b99df3ef7ff7034eb7f23ffb3b39"
S = "${WORKDIR}/phoronix-test-suite"
+inherit systemd allarch
+
do_install() {
DESTDIR=${D} ./install-sh ${exec_prefix}
+
+ if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
+ install -d ${D}/${systemd_unitdir}/system/
+ mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
+ rm -rf ${D}/usr/lib/
+ fi
}
-RDEPENDS_${PN} = "php-cli"
+SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
+RDEPENDS_${PN} += "bash python php-cli"
+
FILES_${PN} += " \
${datadir}/phoronix-test-suite \
${datadir}/appdata/phoronix-test-suite.appdata.xml \
${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
${datadir}/mime/packages/openbenchmarking-mime.xml \
+ ${systemd_unitdir}/* \
"