aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-26 11:35:18 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:32 +0200
commitff77141b96a73fb79b72ab7879008621dc92dc1a (patch)
tree3a144ea3f0c15de5108a72c2a086c502af504ed7 /meta-oe/recipes-benchmark
parentfd9b6aa1d3f07b8986c8d3a56b85076f204bba8c (diff)
downloadmeta-openembedded-contrib-ff77141b96a73fb79b72ab7879008621dc92dc1a.tar.gz
glmark2: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch31
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb9
2 files changed, 36 insertions, 4 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch b/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch
new file mode 100644
index 0000000000..cdf09faec8
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch
@@ -0,0 +1,31 @@
+From 35e9f80518d666db5f9c62e8072ffbc307b4af4f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 26 Aug 2017 08:30:01 -0700
+Subject: [PATCH] Fix clang warnings
+
+../src/native-state-drm.cpp:334:20: error: cannot pass object of non-trivial type 'std::__cxx11::basic_string<char>' through variadic function; call will abort at runtime [-Wnon-pod-varargs]
+ dev_path);
+ ^
+1 error generated.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/native-state-drm.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/native-state-drm.cpp b/src/native-state-drm.cpp
+index dc2b323..62566ee 100644
+--- a/src/native-state-drm.cpp
++++ b/src/native-state-drm.cpp
+@@ -331,7 +331,7 @@ static int open_using_udev_scan()
+ if (!valid_fd(fd)) {
+ // %m is GLIBC specific... Maybe use strerror here...
+ Log::error("Tried to use '%s' but failed.\nReason : %m",
+- dev_path);
++ dev_path.c_str());
+ }
+ else
+ Log::debug("Success!\n");
+--
+2.14.1
+
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 4c5e0567b9..d3766d916f 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -15,10 +15,11 @@ PV = "2017.07+${SRCPV}"
COMPATIBLE_HOST_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '.*-linux*', 'null', d)}"
SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
- file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
- file://Fix-configure-for-sqrt-check.patch \
-"
-SRCREV = "182dcbffe5c8483eadff025b429ee1aacc69c6c2"
+ file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
+ file://Fix-configure-for-sqrt-check.patch \
+ file://0001-Fix-clang-warnings.patch \
+ "
+SRCREV = "ed20c633f1926d1dd78e3e89043c85a81302cbe6"
S = "${WORKDIR}/git"