aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
diff options
context:
space:
mode:
authorchase maupin <chase.maupin@ti.com>2012-02-29 12:46:59 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-29 14:52:45 +0100
commitf742316e223b911c005fb85f7defd8ae891e34e2 (patch)
treecde05e38cd040cf39747faed71e5458632dd8f63 /meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
parent4c9740b5a893255326efa62fb8dd60153f88da2d (diff)
downloadmeta-openembedded-contrib-f742316e223b911c005fb85f7defd8ae891e34e2.tar.gz
nbench-byte-2.3.3: import recipe from oe-classic
* Import the nbench-byte recipe from the oe-classic git repo at git://git.openembedded.org/openembedded commit id: * 6fe7cef27069415f2eba36bc640cf59013d4979b * Update LICENSE checksums * Tested on an AM335x EVM which is the same processor as the beaglebone. * Original Author: * Marcin Juszkiewicz <marcin@juszkiewicz.com.pl> * Modifications by: * Koen Kooi <koen@openembedded.org> * Martin Jansa <Martin.Jansa@gmail.com> * Chris Larson <chris_larson@mentor.com> Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb')
-rw-r--r--meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
new file mode 100644
index 0000000000..8dd289bc67
--- /dev/null
+++ b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
+designed to expose the capabilities of a system's CPU, FPU, \
+and memory system."
+HOMEPAGE = "http://www.tux.org/~mayer/linux/"
+LICENSE = "freely distributable"
+LIC_FILES_CHKSUM = "file://README;beginline=57;endline=66;md5=020ef579f8fa5746b7e307a54707834f"
+SECTION = "console/utils"
+
+SRC_URI = "http://www.tux.org/~mayer/linux/${PN}-${PV}.tar.gz \
+ file://nbench_32bits.patch"
+
+SRC_URI[md5sum] = "285dfab361080759d477ea1fe7d3093a"
+SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac"
+
+TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
+do_compile() {
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0644 NNET.DAT ${D}${bindir}/
+ install -m 0755 nbench ${D}${bindir}/
+}