aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/nbench-byte/nbench-byte
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-06-04 20:09:39 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-13 13:38:10 +0200
commit75ca64e5917d0177c48f58f631497a05e2773731 (patch)
tree8de2180d04046b2eba709edad08c0bf0433be252 /meta-oe/recipes-benchmark/nbench-byte/nbench-byte
parent0c8de928a293e17f7d562fe0dd4b1a8966f1bba2 (diff)
downloadmeta-openembedded-contrib-75ca64e5917d0177c48f58f631497a05e2773731.tar.gz
nbench-byte: Fix parallel building error
This extends the dependencies on pointer.h to fix following error: | ./sysinfo.sh arm-poky-linux-gnueabi-gcc ... | In file included from misc.h:36:0, | from misc.c:23: | nmglobal.h:29:21: fatal error: pointer.h: No such file or directory | #include "pointer.h" | ^ | compilation terminated. | make: *** [misc.o] Error 1 | make: *** Waiting for unfinished jobs.... | ERROR: oe_runmake failed | WARNING: exit code 1 from a shell command. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/nbench-byte/nbench-byte')
-rw-r--r--meta-oe/recipes-benchmark/nbench-byte/nbench-byte/Makefile-add-more-dependencies-to-pointer.h.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte/Makefile-add-more-dependencies-to-pointer.h.patch b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte/Makefile-add-more-dependencies-to-pointer.h.patch
new file mode 100644
index 0000000000..abdb4344bd
--- /dev/null
+++ b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte/Makefile-add-more-dependencies-to-pointer.h.patch
@@ -0,0 +1,23 @@
+Makefile: add more dependencies to pointer.h
+
+Upstream-Status: Inappropriate [no upstream]
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 915866d..edd9ea2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -122,7 +122,7 @@ emfloat.o: emfloat.h emfloat.c nmglobal.h pointer.h Makefile
+ pointer.h: Makefile
+ touch pointer.h ;
+
+-misc.o: misc.h misc.c Makefile
++misc.o: misc.h misc.c nmglobal.h pointer.h Makefile
+ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+ -c misc.c
+
+