aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-08-29 16:17:51 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-01 16:30:32 +0200
commita577b53823d5a0e078777a5fb56a1e3d776b3130 (patch)
treeacb6e7659046119b5407786b2f38b188d5019355 /meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
parent5c36440b5721550c0b61f4d70af5f743223204fb (diff)
downloadmeta-openembedded-contrib-a577b53823d5a0e078777a5fb56a1e3d776b3130.tar.gz
lmbench: Add version 3.0-a9 (initial recipe)
* Imported from oe.dev commit id bac6441118e0b78d55c98afdc108f03b6c655909. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb')
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
new file mode 100644
index 0000000000..7efdad53f4
--- /dev/null
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "Tools for performance analysis."
+HOMEPAGE = "http://lmbench.sourceforge.net/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+ file://COPYING-2;md5=8e9aee2ccc75d61d107e43794a25cdf9"
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
+ file://lmbench-run \
+ file://rename-line-binary.patch \
+ file://update-results-script.patch \
+ file://obey-ranlib.patch \
+ "
+SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
+SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
+
+EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB}" CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
+ TARGET="${TARGET_OS}" BASE="${prefix}"'
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ . ${CONFIG_SITE}
+ if [ X"$ac_cv_uint" = X"yes" ]; then
+ CFLAGS="${CFLAGS} -DHAVE_uint"
+ fi
+ install -d ${S}/bin/${TARGET_SYS}
+ oe_runmake -C src
+}
+
+do_install () {
+ install -d ${D}${localstatedir}/run/lmbench \
+ ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \
+ ${D}${datadir}/lmbench/scripts
+ oe_runmake 'BASE=${D}${prefix}' \
+ -C src install
+ mv ${D}${bindir}/line ${D}${bindir}/lm_line
+ mv ${D}${prefix}/man/* ${D}${mandir}/
+ install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
+ sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
+ -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' \
+ -e 's,^CONFIG=.*$,CONFIG=$SHAREDIR/`$SCRIPTSDIR/config`,;' \
+ ${D}${bindir}/lmbench-run
+ install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
+ install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
+}
+
+RDEPENDS_${PN} = "debianutils"
+FILES_${PN} += "${datadir}/lmbench"