aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/iperf3
diff options
context:
space:
mode:
authormike.looijmans@topic.nl <mike.looijmans@topic.nl>2015-01-26 09:42:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:31:52 +0100
commit01a47ecc1af49e95c997539caf1923f074bf20ce (patch)
tree9b6d64ba697388d3090f3b0f2f33da911715f60a /meta-oe/recipes-benchmark/iperf3
parentf6f4cadd65c7609776b5e6946e2448bee22397d0 (diff)
downloadmeta-openembedded-contrib-01a47ecc1af49e95c997539caf1923f074bf20ce.tar.gz
iperf3: Add native support
If you want to use iperf3 to measure your board's IP performance, you may also want to compile if for the build host, because unlike iperf, iperf3 isn't readily available as a standard Ubuntu package for example. Add a BBCLASSEXTEND="native" to the recipe so that you just can build iperf3-native and have bitbake compile it for you, instead of having to download, compile and install it manually on the build machine. Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/iperf3')
-rw-r--r--meta-oe/recipes-benchmark/iperf3/iperf3_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb b/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
index d34eb693c5..b4d2b6193d 100644
--- a/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
+++ b/meta-oe/recipes-benchmark/iperf3/iperf3_git.bb
@@ -23,3 +23,4 @@ SRCREV = "de420cc741dd8967ebc57f80b7712556442de81b"
S = "${WORKDIR}/git"
inherit autotools
+BBCLASSEXTEND = "native"