aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-08-29 12:15:22 +0500
committerNoor Ahsan <noor_ahsan@mentor.com>2011-08-29 12:15:22 +0500
commit79d102b2c42443d6a089ba85639de8e1e3721e25 (patch)
tree95c57aa0a3da3439942595d78433d884035ca46d /meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
parent0efa8c83632b62007db2a307b9264eb6bd0ac82f (diff)
downloadmeta-openembedded-contrib-79d102b2c42443d6a089ba85639de8e1e3721e25.tar.gz
iperf: Add version 2.0.4 (initial recipe)
* Imported from oe.dev commit id 0ff10ecb88de73074ae4857046643cef15dc4e97 and c10c33f86903c93611023197a7f812459c2dfe2d. * Combined .inc and bb file from oe.dev and made a single bb file. * Removed EXTRA_OECONF_append_epia = " --disable-threads" while importing as this should go in epia layer. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb')
-rw-r--r--meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb b/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
new file mode 100644
index 0000000000..bd8bac126b
--- /dev/null
+++ b/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
+HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
+SECTION = "console/network"
+LICENSE = "NewBSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/iperf/iperf-${PV}.tar.gz \
+ file://000-Iperf_Fix-CPU-Usage.diff \
+ file://001-cast-to-max_size_t-instead-of-int.patch \
+ file://003-fix-hyphen-used-as-minus-sign.patch \
+ file://004-svn-r43-ro.patch \
+ file://005-iperf-die-on-bind-fail.patch \
+ file://006-iperf-die-on-connect-fail.patch \
+ file://007-iperf-reporter-deadlock.patch \
+ file://008-numofreport.patch \
+ file://009-delayloop.patch \
+ "
+
+
+SRC_URI[md5sum] = "8c5bc14cc2ea55f18f22afe3c23e3dcb"
+SRC_URI[sha256sum] = "3b52f1c178d6a99c27114929d5469c009197d15379c967b329bafb956f397944"
+
+inherit autotools
+
+S="${WORKDIR}/iperf-${PV}"
+
+EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+do_configure() {
+ export ac_cv_func_malloc_0_nonnull=yes
+ gnu-configize
+ oe_runconf
+}
+
+do_compile() {
+ cd ${WORKDIR}/iperf-${PV}
+ oe_runmake
+}
+
+do_install() {
+ cd ${WORKDIR}/iperf-${PV}/src
+ oe_runmake DESTDIR=${D} install
+}
+
+