aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/bonnie
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-08-30 21:08:32 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-01 13:05:42 +0200
commit0c5db4e86d35f0fdd1e2077ece2f7f8af86e85bb (patch)
tree71da1ac15b40a2a032431b20f90dfb1fcaf18317 /meta-oe/recipes-benchmark/bonnie
parent2917b4f41c2731c91fa55057ca5172f1915ccddb (diff)
downloadmeta-openembedded-contrib-0c5db4e86d35f0fdd1e2077ece2f7f8af86e85bb.tar.gz
bonnie++: Add version 1.03c (initial recipe)
* Imported from oe.dev commit id 44985d56bc556786812a0a02d6219afd31a7381d. * Merge .bb and .inc file. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/bonnie')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb32
-rw-r--r--meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch19
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
new file mode 100644
index 0000000000..7a6b798bdb
--- /dev/null
+++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Tests large file IO and creation/deletion of small files."
+HOMEPAGE = "http://www.coker.com.au/bonnie++/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
+
+SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \
+ file://gcc-4.3-fixes.patch \
+ "
+SRC_URI[md5sum] = "77a1ba78f37bdd7f024b67e1e36ad151"
+SRC_URI[sha256sum] = "c674f1182f4c20f1e6d038feceb0a6617fc3e7658dfbbac89396043b49612a26"
+
+inherit autotools
+
+SCRIPTS = "bon_csv2html bon_csv2txt"
+EXES = "bonnie++ zcav"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_install () {
+ install -d ${D}/bin
+ install -d ${D}/sbin
+ install -m 0755 ${EXES} ${D}/sbin
+ install -m 0755 ${SCRIPTS} ${D}/bin
+}
+
+PACKAGES =+ "bonnie-scripts"
+
+FILES_${PN} = "${base_sbindir}"
+FILES_bonnie-scripts = "${base_bindir}"
+
+
+
diff --git a/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch b/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch
new file mode 100644
index 0000000000..67f1b74948
--- /dev/null
+++ b/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch
@@ -0,0 +1,19 @@
+Includes string.h to one of the source file.
+
+Upstream-Status: Inappropriate [not author.]
+---
+ zcav.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: bonnie++-1.03a/zcav.cpp
+===================================================================
+--- bonnie++-1.03a.orig/zcav.cpp
++++ bonnie++-1.03a/zcav.cpp
+@@ -15,6 +15,7 @@ using namespace std;
+ #else
+ #include <vector.h>
+ #endif
++#include <string.h>
+
+ // Read the specified number of megabytes of data from the fd and return the
+ // amount of time elapsed in seconds.