aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-08-30 21:08:32 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-01 13:05:42 +0200
commit0c5db4e86d35f0fdd1e2077ece2f7f8af86e85bb (patch)
tree71da1ac15b40a2a032431b20f90dfb1fcaf18317 /meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch
parent2917b4f41c2731c91fa55057ca5172f1915ccddb (diff)
downloadmeta-openembedded-contrib-0c5db4e86d35f0fdd1e2077ece2f7f8af86e85bb.tar.gz
bonnie++: Add version 1.03c (initial recipe)
* Imported from oe.dev commit id 44985d56bc556786812a0a02d6219afd31a7381d. * Merge .bb and .inc file. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch b/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch
new file mode 100644
index 0000000000..67f1b74948
--- /dev/null
+++ b/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch
@@ -0,0 +1,19 @@
+Includes string.h to one of the source file.
+
+Upstream-Status: Inappropriate [not author.]
+---
+ zcav.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: bonnie++-1.03a/zcav.cpp
+===================================================================
+--- bonnie++-1.03a.orig/zcav.cpp
++++ bonnie++-1.03a/zcav.cpp
+@@ -15,6 +15,7 @@ using namespace std;
+ #else
+ #include <vector.h>
+ #endif
++#include <string.h>
+
+ // Read the specified number of megabytes of data from the fd and return the
+ // amount of time elapsed in seconds.