aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-12 21:52:36 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-12 12:57:44 -0700
commita2928764c2116156e0e13c674ab5d6292a053842 (patch)
tree45e952a53fdacb58a05d66e3d3f5361cbc8c313d /meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb
parent22f8afa7afe4d6a3b0b4af0f3ec2f5bfd0661d8f (diff)
downloadmeta-openembedded-contrib-a2928764c2116156e0e13c674ab5d6292a053842.tar.gz
analyze-suspend: update to 5.5
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb')
-rw-r--r--meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb b/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb
new file mode 100644
index 0000000000..bb0aad3413
--- /dev/null
+++ b/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Analyze Suspend"
+DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \
+the activity between suspend and resume, allowing them to identify \
+inefficiencies and bottlenecks."
+HOMEPAGE = "https://01.org/suspendresume"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+# Apart from the listed RDEPENDS, analyze-suspend depends on some features
+# provided by the kernel. These options are:
+# - CONFIG_PM_DEBUG=y
+# - CONFIG_PM_SLEEP_DEBUG=y
+# - CONFIG_FTRACE=y
+# - CONFIG_FUNCTION_TRACER=y
+# - CONFIG_FUNCTION_GRAPH_TRACER=y
+
+RDEPENDS_${PN} += "python-core python-datetime python-stringold"
+
+SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https"
+SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py
+ install -Dm 0644 README ${D}${docdir}/analyze-suspend/README
+}
+
+BBCLASSEXTEND = "native"