aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-11-01 12:49:10 +0100
committerKhem Raj <raj.khem@gmail.com>2021-11-02 08:07:17 -0700
commit659b72bb1c891dc6b74a8dd770640c5997c3be2b (patch)
treef6ce0c0bcc91c8c3006c583694075f48420c14e5 /meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch
parenteb8d2568d0b48f30fe39a6bbe4a59bf32107f3b5 (diff)
downloadmeta-openembedded-contrib-659b72bb1c891dc6b74a8dd770640c5997c3be2b.tar.gz
mozjs-78: Initial add
* Did not get rid of checks using llvm-objdump. So depend either llvm-native from oe-core or clang-native from meta-clang * Unfortunately we still need python3-six(-native) although firefox ships a version in third_party. If somebody more clever than me can solve this, mozjs-78 can be moved out of dynamic-layers * Get rid of erroneous dependency trying to satisfy llvm_objdump It was tested improperly so configure faile for meta-clang not in layers It is not necessary for building js only - see mozjs-91 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch')
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch
new file mode 100644
index 0000000000..665eace665
--- /dev/null
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78/0004-Cargo.toml-do-not-abort-on-panic.patch
@@ -0,0 +1,33 @@
+From 9e37248870b2b955293754933c789ca00bca06ef Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Fri, 1 Oct 2021 13:00:24 +0200
+Subject: [PATCH] Cargo.toml: do not abort on panic
+
+OE's rust is configured to unwind, and this setting clashes with it/
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ Cargo.toml | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 897daad41b..505454263e 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -56,13 +56,11 @@ opt-level = 1
+ rpath = false
+ lto = false
+ debug-assertions = true
+-panic = "abort"
+
+ [profile.release]
+ opt-level = 2
+ rpath = false
+ debug-assertions = false
+-panic = "abort"
+
+ [patch.crates-io]
+ libudev-sys = { path = "dom/webauthn/libudev-sys" }